PDA

View Full Version : Fedora 7 and nvidia via Livna



sentry
13th June 2007, 09:29 PM
My fresh Fedora install is giving me a lot of headaches when it comes to nvidia. My card is a 7800GT and I use the kernel modules from Livna and it just seems to not work properly. The issue seems to be with 3D acceleration or something. Running glxgears = crash, even running glxinfo | grep direct will crash my system.

Here's my X config file;

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1280x960" "1280x800" "1280x720" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
I've actually had some success in modifying it to match the config file posted here (http://forums.fedoraforum.org/forum/showthread.php?t=157177&highlight=nvidia) by leigh123@linux and it seemed to actually work. However, when I rebooted my machine and not just X the config file was erased and the one posted above replaced it :mad:

So how am I to fix this issue? Anyone??

Seve
13th June 2007, 09:41 PM
Hello:
The additional rpm package that is installed as a dependency from livna :
livna-config-display.noarch
is what is causing your manual changes to be over-written each time you restart your X server.
It may be well meaning, however, in your case, just like mine it causes more problems than solutions.
I have a 7800gtx (2)
To avoid the issues that you are having, I removed the kmod-nvidia package and used the rpm package from freshrpms
$ rpm -aq | grep nvidia
nvidia-x11-drv-1.0.9762-3
http://moonshine.freshrpms.net/

You may want to have a look at this option as well :)

Seve

Firewing1
13th June 2007, 09:56 PM
Hello:
The additional rpm package that is installed as a dependency from livna :
livna-config-display.noarch
is what is causing your manual changes to be over-written each time you restart your X server.
It may be well meaning, however, in your case, just like mine it causes more problems than solutions.
I have a 7800gtx (2)
To avoid the issues that you are having, I removed the kmod-nvidia package and used the rpm package from freshrpms
$ rpm -aq | grep nvidia
nvidia-x11-drv-1.0.9762-3
http://moonshine.freshrpms.net/

You may want to have a look at this option as well :)

Seve
I create and maintain livna-config-display so I can help ;) You should have submitted a bug about what happened so I could fix it, I had no idea it was replacing other xorg.conf options (just for the record I'm not trying to get you to switch back to my stuff or promote my code, I just want to make my code work as I meant it to)

Have you pinpointed exactly what part of Leigh's xorg.conf made things work? It for sure won't be the AIGLX / Composite part as that's enabled by default. Can you please try adding these lines to the Device section one by one and restarting X to see which one makes things work?

Option "TripleBuffer" "true"
Option "AllowGLXWithComposite" "True"
Option "RenderAccel" "True"
Once we find the line I'll add it to the list of livna-config-display's things to configure.
Firewing1

Seve
13th June 2007, 10:25 PM
Hello Firewing1:
Yes, I am aware that you are the maintainer and also that you have done a heck of job :)

Should I file the issues in a formal bug or would you like to see them now ?


Seve

Firewing1
14th June 2007, 01:08 AM
Whatever's easier for you - Bug is preferred though since the other maintainers can see it, too.
Firewing1

sentry
14th June 2007, 03:36 PM
Thanks for both of your responses. I'll probably end up using the rpm from freshrpm's until this issue gets resolved.

@firewing - I'll see if adding those options work.

Cheers.