PDA

View Full Version : Enable, Dissable Mouse Pad on Laptop



telepatico
13th June 2007, 08:48 PM
Is there anyway to enable and disable the mouse or soft pad on Linux? While I have full size keyboard, my hands still too big and screw up by accidentally touching the touch pad or whatever that thing on the laptop is called.

I need to disable while at home, since I got the wireless mouse working fine.
Thanks.

jvroig
14th June 2007, 02:12 AM
Only one of my laptops can do that. The HP Pavilion has a button that enables/disables the touchpad. My Neo Qnote unfortunately doesn't have any. As far as I know, if the laptop doesn't have such a button, then you are stuck with an ever-active touchpad, even if you have a mouse plugged in.

A.Serbinski
14th June 2007, 05:38 AM
Sometimes, the buttons are labeled very poorly. On Acer laptops, the symbol is a square with a finger pointing into it.

telepatico
14th June 2007, 07:50 PM
On Windows, I was able to download another driver from the manufacturer, giving me the option of turning the thing off. In Fedora, I am looking at the x11org.config file. There was something about adding some lines to be able to turn it on and off.

My keyboard has function f4 for that purpose, but it doesn't work on Linux or Windows.

KKJensen
14th June 2007, 09:15 PM
Aside from the HP pavilions (which have a big button with a light next to the touchpad) most laptops I have seen disable the touchpad on a hardware level so your X11.org file shouldn't need to be touched. Look at all the F-keys on the laptop for the little (normally blue) symbols, one of them should resemble a touchpad or mouse. Holding the FN key down (in the bottom left corner of the keyboard, normally between Ctrl and the windows button) and hitting this F key (F7 on my acer) shuts off the touchpad.

A long time ago I had an old Dell which, in the bios settings at boot, you could pick "always leave touchpad on" "Always off" and "turn off when PS2 mouse present".

telepatico
14th June 2007, 09:35 PM
I do have a new driver from HP, and that provides me with a menu with more options to deal with this, but on Windows environment only. I do have the F4 key designed for this task, but it doesn't work, not on Linux, not on Windows.

KKJensen
14th June 2007, 09:59 PM
Maybe try a program called "keytouch". I'm investigating it as we speak but apparently it's able to recognize other buttons etc. Maybe it might help. Sorry I can't offer any more advice.


[EDIT] forget that comment...it doesn't do anything with mice from the looks of it.

telepatico
15th June 2007, 12:36 AM
I just talk to HP customer support, and was instructed to do as follows:
Start, Run, msconfig, then un check eabsevr on the start up tab. Of course I check that tab and any other tabs, and there was nothing about it. So there was no solution. I had to reboot, so could not talk back to them.

I tried under the windows environment, to try then under Linux, to see if that would change anything.

Under Fedora, I have tried to edit the xorg.conf, but after adding lines as per forum indications, nothing was helpful.

I am getting used to Fedora, and using windows just to use my stock trading software, since the broker software need Java. I did installed Java on Fedora, but then the second monitor wont work and affects the X11 server.

Well, I will try my best to solve the second monitor issue. The touchpad is getting in my nerves, since every time I type, it mess up what Iam doing, and I am affraid to mess up any Fedora configuration files, while working on them.