PDA

View Full Version : moniter troubles..



xindo
12th June 2007, 03:51 AM
so i have been using openSUSE 10.2 for about a month or so. Its my first experiance with linux and when i first got it, i was having troubles with my moniter. i got past the installation and then rebooted and got past the boot screen and when it should have shown the login screen my screen went black and it said "Input Not Supported". As it turned out i just need the correct driver for my graphics card. after that, it was fine. I mananged to get that driver because it decided to work one time miraculasly and i downloaded and installed quick. now ive decided to try FC 7, so i made a live CD and booted it. After a while the process came to a point where the same "Input Not Supported" message was displayed. I can only guess that this was the login or desktop or whatever... so my question is is there anything i can do to make it work??

Edit:
Moniter: Acer AL1916 and it is not widescreen

yes, i can get into console mode

tashirosgt
13th June 2007, 11:08 PM
Perhaps you mention your specific hardware, someone will know the answer. Can you get in a console mode with CTRL-ALT-F2 ? See if /var/log/Xorg.0.log or Xorg.1.log shows error messages about starting the X server.

tashirosgt
13th June 2007, 11:08 PM
Perhaps if you mention your specific hardware, someone will know the answer. Can you get in a console mode with CTRL-ALT-F2 ? See if /var/log/Xorg.0.log or Xorg.1.log shows error messages about starting the X server.

xindo
19th June 2007, 07:02 AM
.......................................

tashirosgt
19th June 2007, 05:09 PM
I'm not clear on whether you installed the driver you got for your monitor in Fedora as well as in SUSE.

In the console mode, examine /var/log/Xort.0.log and see if any errors are reported. Does SUSE use the /etc/X11/xorg.conf file to configure X, like most distros do? If you have a copy of that file that works you might try using with Fedora.

xindo
19th June 2007, 09:25 PM
like i said, i'm new to linux, so im not sure how to answer. but it is a Live CD version of fedora. can you even install drivers?
im not sure is SUSE uses xorg.conf, though i am leaning toward yes. i only installed a driver for SUSE, and i was wondering two things:
1) can i install drivers when useing a live CD version of fedora?
2) if i can, how do i do that from console mode

what were you suggesting with the xorg.conf file?

tashirosgt
19th June 2007, 10:42 PM
I meant to compare xorg.conf from the SUSE installation to the one on the Fedora installation and see if they are the same. I'm not familiar with running Fedora from a live cd. Can you create a new version of it? If so, you could try replacing its xorg.conf file with the one from SUSE.. When I think of installing drivers, I think of "inserting modules in the kernel". This can be done from the command line. The insmod command does this, but there might be a more modern way. You have to have the right version of the module (driver) on a file that the system can read.

xindo
20th June 2007, 01:48 AM
how would i compare them, and then if they are the same, how would i replace the xorg.conf file for a new disc?


btw, i tryed booting fedora from the cd and went to console, then logged in as root, and tried /var/log/Xorg.0.log and it said "Permission Denied"

tashirosgt
20th June 2007, 02:17 PM
You know more about making the live cd that I do! My way of comparing the files would be copy them to the same directory and then look at them with a text editor in a terminal window. You might prefer to do this operation by a gui file browser (I assume SUSE has one) and open the file with an application like gedit or even the Open Office word processor.

After you logged in the console, you were almost doing the right thing. You need to run a program to view the file and the simplest program is called "less". Try
less /var/log/Xorg.0.log
Then use the up and down arrow keys to read the file and 'q' to quit.
When you typed the file name by itself, the shell thought you wanted to run that file as a program. But the file is not executable, so it said "Permission Denied".

alpha645
20th June 2007, 03:02 PM
You said you needed to install the drivers for your system. You can test this with the live CD however, starting the X-server without the correct driver is not recommended in your case. What you could do is:

- Boot the livecd without starting X (you come in a simple console)
- Grab the driver for your video card (this can be on a USB or from the net however you need to know the url though as there is not GUI browser)
- Install the driver (assuming you have an ati or nvidia the xorg.conf is automatigally updated)

If you want to know how this is done, drop a post. (I'm not gonna type everything for nothing :p )

Note, that this will all be gone once you reboot.....

xindo
21st June 2007, 01:07 AM
You said you needed to install the drivers for your system. You can test this with the live CD however, starting the X-server without the correct driver is not recommended in your case. What you could do is:

- Boot the livecd without starting X (you come in a simple console)
- Grab the driver for your video card (this can be on a USB or from the net however you need to know the url though as there is not GUI browser)
- Install the driver (assuming you have an ati or nvidia the xorg.conf is automatigally updated)

If you want to know how this is done, drop a post. (I'm not gonna type everything for nothing :p )

Note, that this will all be gone once you reboot.....

yeah i think im going to need some instruction on this. by USB you mean jumpdrive or what?

instructions for both would be nice.
edit: i have an nvidia GeForce 6600

alpha645
21st June 2007, 02:02 PM
yeah i think im going to need some instruction on this. by USB you mean jumpdrive or what?

instructions for both would be nice.
edit: i have an nvidia GeForce 6600

Actually it's not that hard, I think you can use the kmod-fglrx and kmod-nvidia from livna. If you have an internet connection when using the LiveCD do:

- Reboot computer
- Add '3' as bootparameter (instructions follow)
- Chose the boot option that suites you (RAM +1 or not)
- Select that boot option and press 'e'
- Select the second line and add to the end: '3'
- Press enter and then press 'b'

I'm not completely sure if you will boot in init, but it should work. You should after the boot see a terminal, log in as root and do:

rpm -i http://rpm.livna.org/livna-release-7.rpm
yum clean all

Based on your card:

NVIDIA:

yum install kmod-nvidia

ATI: (DOES NOT WORK WITH F7 ATM)

yum install kmod-fglrx

Finally start the X server (xorg.conf is automagically configured):

init 5

Hope it works :)

xindo
23rd June 2007, 08:05 PM
i couln't figure out the adding 3 to the boot parameters, but i tried the rest anyway, but it didnt work.

alpha645
24th June 2007, 02:44 PM
Well, once you enter the grub boot menu. You see multiple options. One is for people that have 1 gig of ram or more. Or for people with less than 1 gig of ram. Select the one that fits you (DONT PRESS ENTER!). Press 'e' instead. You should see something like:

root (hd0,8)
kernel /boot/bzImage.2.4.18 ro root=LABEL=/ hdd=ide-scsi 3
initrd /boot/initrd-2.4.18-19

You need to put '3' in the second line as done above.

But about your last post, what went wrong? You need to be more specific. Did the yum install kmod-nvidia install anything? What was the error when going to init 5 (starting X)? What went wrong adding the '3' as bootparameter?

xindo
24th June 2007, 11:52 PM
well for starters, on the live cd edition there is no grub boot loader, it just has an option for w/o 1 BG ram, and option for with 1 GB, and a third irrelevant option i cant remeber. so pressing e instead of enter did nothing... kmod-nvidia installed something and acted as though everything went fine, but i still cant see anything other than console mode

alpha645
25th June 2007, 08:34 AM
well for starters, on the live cd edition there is no grub boot loader, it just has an option for w/o 1 BG ram, and option for with 1 GB, and a third irrelevant option i cant remeber. so pressing e instead of enter did nothing... kmod-nvidia installed something and acted as though everything went fine, but i still cant see anything other than console mode

hmm, then I was wrong about the bootloader. But after you install kmod-nvidia, you have to start X. You do that by typing:

init 5

as su. If something goes wrong, post the generated /etc/X11/xorg.conf and /var/log/Xorg.0.log . You just have to copy these to an USB drive and upload them to the forums.