PDA

View Full Version : Beryl broken afteer xorg-x11-server-Xorg update



bowens44
10th June 2007, 02:20 PM
After doing an update on xorg-x11-server-Xorg.i386 1.3.0.0-7.fc7 today, I have found that Beryl no longer works. When I try to run Beryl manager, the session ends and I find myself back at the login prompt. IUs there a way undo this update?

bowens44
10th June 2007, 02:35 PM
never mind. a stupid mistake on my part......

aragorn2909
10th June 2007, 05:51 PM
I'm suffering from the same problem, and for the life of me can't figure out how to fix it. How did you solve it?

Seve
10th June 2007, 06:07 PM
I'm suffering from the same problem, and for the life of me can't figure out how to fix it. How did you solve it?
Hello:
The issue is related to the updates, which, amended the /etc/X11/xorg.conf file

This is what worked for me using a Nvidia Card. :)

Open a terminal and
gedit /etc/X11/xorg.conf
and add back the following section to the file.
For the 32bit Version

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
EndSection
For the 64bit Version

Section "Files"
ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib64/xorg/modules"
EndSection

Save your changes, exit and Ctrl Alt Backspace to restart your Xserver or reboot. ( you may have to reboot, cannot recall)

Then, try to launch beryl-manager again

Seve

aragorn2909
10th June 2007, 06:23 PM
Thanks Seve,

I just fixed the problem by reinstalling the Nvidia driver. Do you know if the method you list will work with future updates?

AB

Seve
10th June 2007, 07:01 PM
Thanks Seve,

I just fixed the problem by reinstalling the Nvidia driver. Do you know if the method you list will work with future updates?

AB
Hello:
No idea ?

Just make a backup of your current working /etc/X11/xorg.conf file.

Then you can always compare to see what changes, if any were made if you have problems.

Seve