PDA

View Full Version : Problem activating TV output as Separate X Screen-GeForce FX 5200



aesio
9th June 2007, 04:11 PM
I'm using the kmod-nvidia driver from livna. I'm able to easily activate TwinView, however I cannot get the separate x screen to activate. Had the same problem in FC6. I'm changing the settings in the NVIDIA X Server Settings. applying the settings that can be changed and saving the Xorg.conf file. After restarting, the TV is disabled completely again. I've tried switching the run-level and complete restart to restart X. Any suggestions would be greatly appreciated.

BigWaxer
10th June 2007, 03:57 AM
I'm using the kmod-nvidia driver from livna. I'm able to easily activate TwinView, however I cannot get the separate x screen to activate. Had the same problem in FC6. I'm changing the settings in the NVIDIA X Server Settings. applying the settings that can be changed and saving the Xorg.conf file. After restarting, the TV is disabled completely again. I've tried switching the run-level and complete restart to restart X. Any suggestions would be greatly appreciated.

So it is working until you restart? If I am understanding this correctly here is what you need to do.

Either or...

Log in as root and perform the same changes in the Nvidia GUI and save to X Configuration file.

If you don't want to log into root. When you go to Save the X Config in the Nvidia Gui, change the file to your home directory and save it there.

Then log into a terminal and type.

su -

cp xorg.conf /etc/X11/


Reason this happens is because xorg.conf is owned by root, so whats happening is when you hit save its not overwriting it since you don't have the proper permissions.