PDA

View Full Version : F7 suspend/resume was working, broke around 2 weeks ago, Dell Inspiron 4100



pkgw
8th June 2007, 08:17 PM
I have a Dell Inspiron 4100 (a really old laptop, I know). I installed Fedora 7 Test 4 on it it when it came out, and I was really happy that for the first time ever, suspend/resume worked on my laptop.

I kept my laptop updated until the official F7 release. Unfortunately, since May 28, some update seems to have made suspend/resume on my laptop stop working. If I try to hibernate, it will shut things down, get to the point of showing "Compressing memory", finish that, and then the screen goes blank and the laptop stays turned on. Before, it printed out a lot more text and the laptop powered off. The only thing that changed besides me applying updates was that I tweaked my network configuration a bit, because the installer had gotten my wireless card (airo_cs) and builtin ethernet (3c59x) confused.

Does anyone have any idea what might have caused things to stop working? I'd be really happy if I could get suspend/resume working again.

Jman
11th June 2007, 03:46 AM
Now with F7 you have hal quirks to try, (http://people.freedesktop.org/~hughsient/quirk/) various bits of nonstandard suspend behavior.

pkgw
11th June 2007, 04:23 AM
My laptop worked with FC7t4, so unfortunately I'm very sure that the quirks aren't the issue. It looks like everything is suspending fine, up until the kernel actually has to power down the machine. And, based on my experience before things broke, if it manages to power down successfully, it will probably come back up OK too.