PDA

View Full Version : Sound Card: Nvidia CK804 Issues.



joeborg
7th June 2007, 10:53 PM
Hi,
I've just installed Fedora 7 with all the latest updates. My sound card was working fine a few reboots ago, however, now it does not seem to work anymore and I'n not quite sure why. The card does not seem to be listed in system-config-sound. However, the output of lspci does list it:

[root@apollo boot]# lspci | grep audio
00:0d.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)

lsmod also seems to show the correct modules loaded so I'm not sure what's going on:

[root@apollo boot]# lsmod | grep snd
snd_intel8x0 45033 0
snd_ac97_codec 120985 1 snd_intel8x0
ac97_bus 11201 1 snd_ac97_codec
snd_seq_dummy 12613 0
snd_seq_oss 40897 0
snd_seq_midi_event 16577 1 snd_seq_oss
snd_seq 63201 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss 53217 0
snd_usb_audio 98625 2
snd_mpu401 18665 0
snd_mpu401_uart 17601 1 snd_mpu401
snd_mixer_oss 25537 1 snd_pcm_oss
snd_usb_lib 26048 1 snd_usb_audio
snd_rawmidi 35137 2 snd_mpu401_uart,snd_usb_lib
snd_pcm 93129 4 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_usb_au dio
snd_seq_device 17109 4 snd_seq_dummy,snd_seq_oss,snd_seq,snd_rawmidi
snd_hwdep 19145 1 snd_usb_audio
snd_timer 32585 2 snd_seq,snd_pcm
snd 71785 18 snd_intel8x0,snd_ac97_codec,snd_seq_oss,snd_seq,sn d_pcm_oss,snd_usb_audio,snd_mpu401,snd_mpu401_uart ,snd_mixer_oss,snd_rawmidi,snd_pcm,snd_seq_device, snd_hwdep,snd_timer
soundcore 17249 1 snd
snd_page_alloc 18897 2 snd_intel8x0,snd_pcm

Strangely, this was all working fine just yesterday...

Let me know if you need further info.

Thanks,

Joe

mpajoh
13th June 2007, 01:52 PM
I just upgraded from FC6 to FC7 and have the same problem.
This problem was there in FC6 also, but it happened once in while.
I will post the output of the commands of the OP when I get to my computer. May be it sheds some light on the problem.
The only thing I can add is that when I tried play an MPG file with XINE, in FC7, it told me "snd_pcm_open() failed no such file or directory", and did not play the file. XINE never did that on FC6. On FC6 when the sound did not work XINE played the MPG file but had no sound.

joeborg
14th June 2007, 10:04 AM
Hi There,
An update on this:
The issue seems to be occuring about 50% of the time (i.e. for 50% of the reboots, the sound card is fine, for 50% it isn't loaded up). I've tried setting PnP OS in the bios to no but this seems to have made no difference. I've read in other threads that it maybe an IRQ allocation issue however, my BIOS (Motherboard A8N32-SLI Delixe ASUS) doesn't provide an option to manually specify an IRQ for the sound card.

The only other suspicion I have is that I have the NVIDIA video card drivers installed but I fail to see how these drivers could be cuasing an issue with the sound card. The other thing I've noticed is that most of the time I cannot shutdown properly from X (as as as I click shutdown/restart it freezez); but I not sure this is related either.

I'm thinking of filing a bug on bugzilla for this issue.

mpajoh
14th June 2007, 02:04 PM
. . .
The issue seems to be occuring about 50% of the time (i.e. for 50% of the reboots, the sound card is fine, for 50% it isn't loaded up)
. . . .So far every boot, about three, since upgrading from FC6 to FC7, sound has not worked. On FC6, about 20% of the time sound did not work.

. . .
I'm thinking of filing a bug on bugzilla for this issue.
. . .If this does not resolve I will too.

joeborg
16th June 2007, 07:32 PM
Hi There,
I've specified 'irqpoll' to the kernel at bootup (i.e. in grub.conf) and now the issue seems to happen less often, however, it still occurs.

In the meantime, I came across this in searching:
http://forums.fedoraforum.org/forum/showthread.php?t=156673&highlight=sound+intel

Also, I came across a post that reported that a webcam maybe the issue so if you have one, you may want to try unplugging it and re-tesintg.

joeborg
16th June 2007, 08:48 PM
Hi,
I think I may have solved this issue. So far it hasn't re-occured in 3-4 reboots and I've also used the webcam. I went to system->administration->sound detection (in a reboot when the card was working). Then clicked the settings tab and order the sound devices such the the nvidia/intel sound card was at the bottom of the list. I saved and it seemed to have done the trick.