PDA

View Full Version : Fedora x86_64 and D-Link DWL-G510 odyssey



xplod
7th June 2007, 03:24 PM
Hi all.

After some hours of resultless work i don't know any further...

I've got OpenSuse 10.0 (for testing purposes), Fedora Core 5, 6 and 7 and drivers from RALink and serialmonkeys page.
Turning the ralink driver on on FC5 results in a system crash. On FC6 and 7 it cam't be installed.
The serialmonkies driver does still work, but just with WEP encryption which is inacceptable for me ( an error message reports that WPA is not supported ).

On Fedora Core 7 a driver called rt61pci is already loaded (a "lsmod |grep rt" revealed its name) so I've got problems installing the serialmonkies one. I added "alias wlan0 rt61pci" to modprobe.conf so that i can configure the device with the gnome network manager, but the system says something like "The device can not be found" or so.

My WLAN Card is a DWL-G510 Revision C2. OpenSuse and FC7 both report a rt61 / rt25xx card with modprobe, but I found no documentation revealing which chip is used on the card.

I want to use my fedora with openoffice and vmware player to be able to use my windows just as a gaming platform with no access to my personal data...

Can anybody help me with this problem? Has anybody been able to use this card with WPA-TKIP encryption and is willing to help me?

Sincerely
Dirk

avandermade
10th June 2007, 04:59 PM
Hi xplod,

An lspci should show you the details of the card. The card uses the RT61 chipset and I've been able to get the card working on FC6 previously (i686 not x86_64).

I have recently installed F7 on my system and am using the same card. I will attempt to get the card working and will get back to you with my findings.

If you have any success or any useful information, it would be appreciated if you could share any information that may help others like myself to configure the card :)

avandermade
10th June 2007, 06:04 PM
Hi xplod,

Please check your dmesg output. It may be possible that the firmware for your card can't be read properly. I found the following in my dmesg output:

rt2x00->rt2x00lib load firmware continued: Error - Failed to read Firmware.

I'll coninue looking at this at a later time and will get back to you on this.

avandermade
10th June 2007, 06:07 PM
Oh ... btw. I checked my lspci output and I've got the revision B version of the DWL-G510 so check your lspci output as you may have a different chipset.

xplod
10th June 2007, 10:34 PM
Thanks for the hint with the firmware. I copied the one from the ralink archive to the /lib/firmware directory and it now seems to load correctly. But that didn't solve my problem:

dmesg says:
< cutted >
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:15:0c:34:7f:51
wlan0: authenticate with AP 00:15:0c:34:7f:51
wlan0: authenticate with AP 00:15:0c:34:7f:51
wlan0: authentication with AP 00:15:0c:34:7f:51 timed out
ADDRCONF(NETDEV_UP): wlan0: link is not ready
< cutted >
The MAC Adress is the one from my router, so the driver seems to work...

LSPCI says:
04:05.0 Network controller: RaLink RT2561/RT61 rev B 802.11g

wpa_supplicant tells:
< cutted >
Setting scan request: 5 sec 0 usec
Starting AP scan (specific SSID)
Scan SSID - hexdump_ascii(len=5):
78 70 6c 6f 64 xplod
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
Wireless event: cmd=0x8b19 len=16
Received 0 bytes of scan results (0 BSSes)
Scan results: 0
Selecting BSS from priority group 0
No suitable AP found.
Setting scan request: 5 sec 0 usec
CTRL-EVENT-TERMINATING - signal 2 received
Removing interface wlan0
State: SCANNING -> DISCONNECTED
wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
No keys have been configured - skip key clearing
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
wpa_driver_wext_set_wpa
wpa_driver_wext_set_drop_unencrypted
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x0 - wpa_driver_wext_set_countermeasures
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - No keys have been configured - skip key clearing
Cancelling scan request
Cancelling authentication timeout
WEXT: Operstate: linkmode=0, operstate=6
< cutted >

avandermade
14th June 2007, 02:39 PM
Could you please send the output of
iwlist wlan0 scan.
Please also check whether you need to set your SSID.

To set you SSID, use
iwconfig wlan0 essid <ESSID> where <ESSID> is that configured on your wireless access point.

Use iwconfig to check whether the ESSID has been set. It may be worthwhile disabling any WEP and security on your access point temporarily to check whether there is an issue with the security.

avandermade
14th June 2007, 02:47 PM
Some searching (googling) seems to suggest there is a driver issue we're dealing with here which would be strange as the driver that came with F7 is being used.

avandermade
14th June 2007, 03:37 PM
Some further searching seems to indicate that in order to configure the SSID and your WEP key, you may need to down the card, then configure it and they up it.

I've been able to re-create the issue on my end and got the following error when trying to get an IP through DHCP:


wmaster0: unknown hardware address type 801

Ujeen
16th June 2007, 12:00 AM
rt2x00->rt2x00lib load firmware continued: Error - Failed to read Firmware.
I've got the same error and I have the same G510 "B" firmware
01:08.0 Network controller: RaLink RT2561/RT61 rev B 802.11g

and the driver is loaded

lsmod | grep rt
rt61pci 25472 0
rt2x00pci 13952 1 rt61pci
rt2x00lib 18816 2 rt61pci,rt2x00pci
parport_pc 29732 1
parport 37704 2 lp,parport_pc
mac80211 135812 3 rt61pci,rt2x00pci,rt2x00lib
eeprom_93cx6 7296 1 rt61pci
crc_itu_t 6272 1 rt61pci
gameport 18952 2 emu10k1_gp

But I didn't catch what I should to do further ?
Please help me, wifigurus :rolleyes:

xplod
16th June 2007, 03:05 PM
This is kind of funny:
I configured wlan0 via the gnome network frontend.
If interface is down the "iwlist wlan0 scan" command returns:


wlan0 Interface doesn't support scanning : Network is down


If I start the network via the frontend:


wlan0 No scan results


But if I shut the interface down and start wpa_supplicant it returns (while it says interface is down)


wlan0 Scan completed :
Cell 01 - Address: 00:15:0C:34:7F:51
ESSID:"xplod"
Mode:Master
Channel:4
Frequency:2.427 GHz
Signal level=-155 dBm Noise level=-1 dBm
Encryption key:on
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
36 Mb/s; 48 Mb/s; 54 Mb/s
Extra:tsf=000000023329d38f


I think wep encryption will work because there never have been problems using wep with all other drivers...

Sincerely
Dirk

Ujeen
16th June 2007, 11:16 PM
I've got it worked.
I recompiled kernel to exclude all wireless drivers.
Then I downloaded rt61 cvs - driver from http://rt2x00.serialmonkey.com/wiki/index.php/Downloads page.
Then I compiled this driver and installed it without any problem.
Then I read README file from driver distributive and did all that there was recommended.
But at this step I didn't manage to get wifi connection up.
Then I downloaded latest version of the Rutilt graphical utility from ralink site (you should be authorized at forem to be able to download)
http://rt2x00.serialmonkey.com/phpBB2/viewtopic.php?t=3867
and from that point my card started working
hurra :)
The question is how to start this interface automatically, because I must for now repeat all the activities I described above with every booting
(sorry for my english)

quinquen
17th June 2007, 03:13 AM
one step, go for the firmware here...

http://kwizart.free.fr/fedora/

I have an rt61 chipset on D-link dwl-630 revE

To work I must start my ethernet card first, why? I don know, but work. Then I put my pcmcia wifi card.

Now I update the kernel... and stop to work, any idea??


pentium4, fc7, 512ram.

xplod
24th June 2007, 06:06 PM
I just got it to work!
The problem is I can't get it to work automatically at boottime

I tried many settings but ping always said "destination host unreachable". But then I tried "iwlist wlan0 sca"n and then I got a connection. I tried to write a startup script:



iwconfig wlan0 mode managed
ifconfig wlan0 up
ifconfig wlan0 inet
ifconfig wlan0 netmask 255.255.255.0
ifconfig wlan0 192.168.2.2
iwpriv wlan0 set AuthMode=WPAPSK
iwpriv wlan0 set EncrypType=TKIP
iwpriv wlan0 set WPAPSK=xxx
iwlist wlan0 scan
route add gw 192.168.2.1


But when i put it into the rc5.d folder as softlink S30WLAN_UP, it won't work. I have to start it manually...
Is there any other solution to get it to work, or do I have to start it manually?

cu
_XploD_