PDA

View Full Version : Control fans?



alpha645
7th June 2007, 10:51 AM
I'm having a small problem with my laptop. When idle, I have:

sda 39 degrees
Core0 60 degrees
Gpu0 70 degrees
THRM 53 degrees

It's an Compaq Presario V6221EU . I got ACPI enabled in the kernel and it's running. However, I have the problem that there is no 'fan' . I already upgraded the BIOS (it's the latest).

tree -f /proc/acpi/
/proc/acpi
|-- /proc/acpi/ac_adapter
| `-- /proc/acpi/ac_adapter/ACAD
| `-- /proc/acpi/ac_adapter/ACAD/state
|-- /proc/acpi/battery
| `-- /proc/acpi/battery/BAT0
| |-- /proc/acpi/battery/BAT0/alarm
| |-- /proc/acpi/battery/BAT0/info
| `-- /proc/acpi/battery/BAT0/state
|-- /proc/acpi/button
| |-- /proc/acpi/button/lid
| | `-- /proc/acpi/button/lid/LID
| | |-- /proc/acpi/button/lid/LID/info
| | `-- /proc/acpi/button/lid/LID/state
| |-- /proc/acpi/button/power
| | |-- /proc/acpi/button/power/PWRB
| | | `-- /proc/acpi/button/power/PWRB/info
| | `-- /proc/acpi/button/power/PWRF
| | `-- /proc/acpi/button/power/PWRF/info
| `-- /proc/acpi/button/sleep
| `-- /proc/acpi/button/sleep/SLPB
| `-- /proc/acpi/button/sleep/SLPB/info
|-- /proc/acpi/dsdt
|-- /proc/acpi/embedded_controller
| `-- /proc/acpi/embedded_controller/EC0
| `-- /proc/acpi/embedded_controller/EC0/info
|-- /proc/acpi/event
|-- /proc/acpi/fadt
|-- /proc/acpi/fan
|-- /proc/acpi/power_resource
|-- /proc/acpi/processor
| `-- /proc/acpi/processor/CPU0
| |-- /proc/acpi/processor/CPU0/info
| |-- /proc/acpi/processor/CPU0/limit
| |-- /proc/acpi/processor/CPU0/power
| `-- /proc/acpi/processor/CPU0/throttling
`-- /proc/acpi/thermal_zone
`-- /proc/acpi/thermal_zone/THRM
|-- /proc/acpi/thermal_zone/THRM/cooling_mode
|-- /proc/acpi/thermal_zone/THRM/polling_frequency
|-- /proc/acpi/thermal_zone/THRM/state
|-- /proc/acpi/thermal_zone/THRM/temperature
`-- /proc/acpi/thermal_zone/THRM/trip_points


Can anyone please help me to turn on cooling continiously? Is this possible ?