PDA

View Full Version : NVIDIA resolution



jgutty
6th June 2007, 05:30 PM
I had FC 5 running with an nVidia Geforce 4 and all was well. When I updated the kernel awhile back, I could not get a resolution above 800x600. I have some posts on this forum about that effort http://forums.fedoraforum.org/forum/showthread.php?t=142698.

I simply made the older kernel the grub default.

I now have a Geforce 5 FX, and the same problem. I get 3d effects ok, the nVidia splash screen comes up, but the only resolution available is 800x600. with the nv diver, I can get 1600.

When I put the new card in, I tried some other distros....Ubuntu. pclinuxos.....same thing.

(BTW, using f7 now.....I like the best of the 3)

One thing I did notice now that I did not notice before is that after init starts, there are a few lines that come up to the effect:

cp.................unable to create special file nvidia1....file already exists
same for nvidia2, nvidia3 and nvidiactl

Those line do not come up when using the nv driver.

I have attached the xorg.conf files from both configs.

An aside, how can I install a previous kernel? I think the new kernel is the problem.

Thanks,

Dies
6th June 2007, 08:56 PM
One thing I did notice now that I did not notice before is that after init starts, there are a few lines that come up to the effect:

cp.................unable to create special file nvidia1....file already exists
same for nvidia2, nvidia3 and nvidiactl

Those line do not come up when using the nv driver.


Thanks,

Those are probably due to Selinux interfering with the Nvidia driver.

http://forum.fedoraforum.org/forum/showpost.php?p=803441&postcount=16

That post contains links to two different solutions, pick one you like.

If you still have issues with the resolution you might want to post an updated xorg.conf.

jgutty
8th June 2007, 01:01 AM
Thanks for the reply.

I don't believe se linux has anything to do with it as it is disabled. Also, ubuntu and pclinux os displayed the same isue.

Anyway, I added the file to udev as suggested....no difference. The problem is not that the driver does not work in 3d accelerated fashion. 3d works fantastic. I have no resolution other that 800 x 600 which is pretty grotesque on a big screen.

I have attached the latest version of the xorg.conf. file, and a screen snap of the livna config window. I think I have stumped all.

I will research how to go back to a previous kernel.

Thanks again!

Dies
8th June 2007, 01:36 AM
Oh yeah if Selinux is disabled then that fix won't help anything.

Strange I've never had this problem after installing the driver, must suck.

You can try something like this if you want, can't hurt.

leadgolem
8th June 2007, 04:14 AM
I have, on occasion had a similar problem. My issue was, the monitor was not auto detected. Under system/admin/display hardware tab. The monitor was listed as being 800x600. Changing it to a generic lcd panel with the correct resolution, then changing the settings tab to reflect that resolution solved the problem.

I hope this is helpful.

jgutty
28th June 2007, 01:43 AM
I just ran a system update that included a kernel update. When I reinstalled the nvidia driver, all works well. I believe the issue was with the kernel