PDA

View Full Version : Sweex Webcam driver problem



jether
6th June 2007, 12:46 PM
I have a sweex 100k Webcam, the drivers I gained from here:
http://www.linux-projects.org/modules/mydownloads/viewcat.php?cid=2

The drivers seem to be the only ones for this webcam, and they have been referred to on this forum a number of times. I downloaded it, untarred it and opened a terminal in the location of where I untarred it. the readme says start of with "make clean" at which point I get this:


m[james@localhost Driver]$ make clean
make -C /lib/modules/`uname -r`/build M=/home/james/Download/Driver clean
make: *** /lib/modules/2.6.21-1.3194.fc7/build: No such file or directory. Stop.
make: *** [clean] Error 2

I looked for the file "build" at the location stated above. It is there but with a strange symbol, like a shortcut but with a lock on it. I click on the file and it says "does not seem to exisit anymore".

So what is the problem? Is the file corrupt, or is there a way around this problem such as another way for fedora to make my webcam work? Thanks for any help.

jether
8th June 2007, 11:49 AM
Can anyone help at all?

Iron_Mike
8th June 2007, 12:10 PM
Open a terminal window and change to root, using su - (that is su dash) and type:

yum install kernel-devel

Then try to compile the driver again......You might get some dependency issues like gcc+ missing etc, so you will have to install these also....

jether
8th June 2007, 12:23 PM
Thanks, the driver is now complied. In the instructions it says that I now need to load the modules into memory, usually done by the command "modprobe sn9c102". However, fedora does not seem to recognize this command. Is there any other way of loading into memory?

jether
8th June 2007, 12:48 PM
Ok don't worry, I managed to get the modprobe working, but the cam is still not working. I am using the viewer here:
http://sn-webcam.sourceforge.net/
Can anyone offer anymore help with this?

jether
8th June 2007, 01:57 PM
Ok don't worry. Nothing a little restart didn't handle...