PDA

View Full Version : usb mouse does not work on F7!



mdogruel
6th June 2007, 11:40 AM
I wonder what could be wrong in my system / configuration that can make a usb mouse not work on my laptop running F7?

When booting while it's plugged it works fine along with the touchpad. But once it's unplugged, it does not work when you re-plug it.

I have a "synaptics" and a "corepointer" sections in my xorg.conf (nvidia).

The modules ehci_hcd, ohci_hcd and uhci_hdc are loaded but none of them are used by any device!

My USB controller (as recognized by fedora) is nVidia MCP51 (rev a3).

Thanks for you help!

Mutlu

jflesher
6th June 2007, 03:59 PM
Sounds like a NVIDIA Driver issue; to find out edit your xorg.conf in ect/X11 as follows
Add Option "HWCursor" "off" to video section; something like

Section "Device"
Identifier "Videocard0"
Driver "nv"
Option "HWCursor" "off"
EndSection

You might have to load the NVIDIA driver to fix this.

alpha645
7th June 2007, 07:06 AM
You do need to add that mice to the server-layout. Can you post your xorg.conf ? (/etc/X11/xorg.conf)

mdogruel
7th June 2007, 05:07 PM
Hi, thank you for the replies.

Adding the line
"option HWCursor" "off" didn't solve the problem.

And yes I included my mice in the server layout :


Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "CorePointer"
InputDevice "Mouse0" "CorePointer"
EndSection

And here is how I added a section for my additional (usb) mouse in my xorg.conf:


Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto"
Option "Buttons" "3"
EndSection

alpha645
7th June 2007, 07:28 PM
Hi, thank you for the replies.

Adding the line didn't solve the problem.

And yes I included my mice in the server layout :



And here is how I added a section for my additional (usb) mouse in my xorg.conf:

Doesn't /dev/input/mice output all the different mice? If I'm correct about this then you should see in that same /dev/input 2 or more devices ranging from mouse0 till mouseX . Perhaps you should list them seperately (I think that mouse0 is the touchpad and mouse1 should be the USB one if detected)

jflesher
7th June 2007, 08:37 PM
Can you list your equipment type: modal of laptop; CPU; RAM; controller chips; video chip set; also are you running the final version of F7? In your BIOS are you set for a plug and play OS? The reason I had you add the Hard ware cursor off was to find out if in fact the mouse was working; if you can't see the mouse cursor you might think its not working when if fact it is; its a problem with the NVIDIA driver. Try this; I know plug & play is fine; but start your system with the mouse pluged in; look in the log files after boot up; attach the var/log/Xorg.o.log for starts; lets see whats really going on.

mdogruel
7th June 2007, 11:01 PM
Thanks for the responses.

Right, the mystery is now solved after several hours of trial & error. I upgraded from FC6, so a lot of settings remained the same which eventually might have caused the trouble.

I changed


ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib64/xorg/modules"

to:


Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

I also added these modules:


Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection


and everything worked just fine! Whether there is a mouse section in the xorg.conf or not.... Both the touchpad and an external usb mouse -- whenever it's plugged.

Something else which also solved the problem:

Deleting xorg.conf!

...so that NVIDIA starts with a fresh conf. Actually, to my surprise, it did not create a new xorg.conf. F7 worked fine without one! The old XF86Config did the trick.

jflesher
8th June 2007, 04:16 AM
Glad to hear you got it working.

I know that a fresh install works the best; but without a good backup I wouldn't suggest it; but you might have a lot of things not work the way they should on an upgrade; even though they did a good job on the upgrade feature; I would like to see a utility that will self repair the OS and reinitialize all the hardware.

F7 will create a new xorg.conf file if you do something that forces it too; i.e. save your video settings; with my NVIDIA chipset it's a pain; it will have to recreate it or my video will only work at 800x600 and I won't have a mouse cursor.

mdogruel
8th June 2007, 09:48 AM
Yes, exactly. But when I forced NVIDIA to create a new configuration file by saving my current settings while there was no existing xorg.conf, it created a file named "XF86Config" under /etc/X11, not a file named xorg.conf.
Thank you for the suggestions and comments.