PDA

View Full Version : FC7 Yum update: Error: Cannot open/read repomd.xml file for repository: livna



Newbie_2007
3rd June 2007, 08:53 AM
I updated my FC7 using below settings. Everything is working, apps wise.

BUT Yum update is NOT working anymore...This is the error

http://rpm.livna.org/fedora/7.89/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://livna.cat.pdx.edu/fedora/7.89/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/7.89/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/7.89/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://mirror.atrpms.net/livna/fedora/7.89/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/7.89/x86_64/repodata/repomd.xml: [Errno 4] IOError: [Errno ftp error] 550 Failed to change directory.
Trying other mirror.
Error: Cannot open/read repomd.xml file for repository: livna

Setting of Livina.repo


[livna]
name=Livna for Fedora Core $releasever - $basearch - Base
baseurl=
http://rpm.livna.org/fedora/$releasever/$basearch/
http://livna.cat.pdx.edu/fedora/$releasever/$basearch/
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/$basearch/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/$basearch/
http://mirror.atrpms.net/livna/fedora/$releasever/$basearch/
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/$releasever/$basearch/
failovermethod=priority
#mirrorlist=http://rpm.livna.org/mirrorlist-7
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna

[livna-debuginfo]
name=Livna for Fedora Core $releasever - $basearch - Debug
baseurl=
http://rpm.livna.org/fedora/$releasever/$basearch/debug/
http://livna.cat.pdx.edu/fedora/$releasever/$basearch/debug/
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/$basearch/debug/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/$basearch/debug/
http://mirror.atrpms.net/livna/fedora/$releasever/$basearch/debug/
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/$releasever/$basearch/debug/
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna
gpgcheck=1

[livna-source]
name=Livna for Fedora Core $releasever - $basearch - Source
baseurl=
http://rpm.livna.org/fedora/$releasever/SRPMS/
http://livna.cat.pdx.edu/fedora/$releasever/SRPMS/
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/SRPMS/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/SRPMS/
http://mirror.atrpms.net/livna/fedora/$releasever/SRPMS/
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/$releasever/SRPMS/
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna
gpgcheck=1


Please share some hints

daneel971
3rd June 2007, 09:38 AM
It happened even to me, regarding freshrpms and fedora.
Try cleaning the yum cache: if it doesn't work, just empty the /var/cache/yum/ directory manually and restart yum.
I think that the servers are a bit overloaded these days.

zenarcher
5th June 2007, 12:43 AM
I'm having the same problem and same error message with Livna. The other repos are fine and I can enable FreshRPM and it works, too. Just have the problem with Livna. It was working a couple of days ago when I installed Fedora 7, but now, nothing.

I tried the suggestions above, but no success. Anyone have an idea?

Cheers,
zenarcher

Seve
5th June 2007, 01:21 AM
Hello:
Assuming that you have not changed anything in your repos, it is most likely just a timing error, where the mirrors are busy of temporarily down ..

Seve

Newbie_2007
5th June 2007, 02:50 AM
Still the same problem after 2 days. I am sure there is some other problem and NOT just only about mirrors not working.

Please share your tips

zenarcher
5th June 2007, 06:01 PM
Same here. I even removed Livna and have tried to reinstall, but when I attempt to reinstall Livna, here is what I get:

[zenarcher@localhost ~]$ su
Password:
[root@localhost zenarcher]# rpm -ivh http://rpm.livna.org/livna-release-7.rpm
Retrieving http://rpm.livna.org/livna-release-7.rpm
Preparing... ########################################### [100%]
package livna-release-7-2 is already installed
[root@localhost zenarcher]#

However, if I do a search I do not find Livna, nor does it appear anywhere in yum, anymore.

Any assistance would be appreciated.

Cheers,
zenarcher

Seve
5th June 2007, 06:42 PM
Still the same problem after 2 days. I am sure there is some other problem and NOT just only about mirrors not working.

Please share your tips
Hello:
Well it is actually about the mirrors not working in your case . :)

From the output of what you posted above :

http://rpm.livna.org/fedora/7.89/x86_64/repodata/repomd.xml:

You will notice that your livna repository search is expecting to find 7.89 ?
Since there is no repository for 7.89, rather only 7
http://rpm.livna.org/fedora/
In the configuration of the standard xxx.repo the macro $releasever picks up the version of Fedora that you are running.
In your case it would appear that you are running a rawhide version of Fedora, which is labeled as 7.89

My guess is that you did not do a fresh install of F7 rather you just kept updating via yum from a previously installed Test version of F7 ??, which means you are running rawhide and not F7.

This is the reason for standard livna repository configuration not working for you.


Seve

zenarcher
5th June 2007, 06:45 PM
I just managed to fix the problem. I had removed Livna, as I stated above. I then followed these instructions and after reinstalling, Livna is working fine again. Hope it helps someone else....

Even if you added the Livna repository during installation, it seems you have to add it again afterwards, which you can do by downloading and installing the livna-release-7.rpm package.

Cheers,
zenarcher

richk
5th June 2007, 06:51 PM
livna on their web sited disc crash. they are partly up on their mirror.

Newbie_2007
6th June 2007, 02:50 AM
>>In your case it would appear that you are running a rawhide version of Fedora, which is labeled as 7.89

>>My guess is that you did not do a fresh install of F7 rather you just kept updating via yum from a previously installed Test version of F7 ??, which means you are running rawhide and not F7.


Hi Seve,

You are absolutely CORRECT !. I have been using FC7 from Test 2 onwards and keep updating via Yum till Test 4 and even few files for FC8.

How Can i fix my updates link for fedora 7 and remove all the files for FC8 ? I don't want to CLEAN INSTALL FC7 ? It will take lot of time and my effort.

Thanks

Please give some tips

Seve
6th June 2007, 03:12 AM
Hello:
Not sure if you have gone past the point of no-return or not ?
Can you post the output of
ls /etc/yum.repos.d/*

Seve

Mandibela
10th August 2007, 05:30 PM
I have the same problem when I try to install VLC.yum gives "Nothing to do"

My ls /etc/yum.repos.d/*

/etc/yum.repos.d/fedora-development.repo
/etc/yum.repos.d/fedora.repo
/etc/yum.repos.d/fedora-updates.repo
/etc/yum.repos.d/fedora-updates-testing.repo
/etc/yum.repos.d/livna-devel.repo
/etc/yum.repos.d/livna.repo
/etc/yum.repos.d/livna.repo~
/etc/yum.repos.d/livna-testing.repo

I'm using FC8test1


AAAnd:

yum install vlc

Setting up Install Process
Parsing package install arguments
http://rpm.livna.org/fedora/7.90/i386/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://livna.cat.pdx.edu/fedora/7.90/i386/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/7.90/i386/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/7.90/i386/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://mirror.atrpms.net/livna/fedora/7.90/i386/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/7.90/i386/repodata/repomd.xml: [Errno 4] IOError: [Errno ftp error] 550 Failed to change directory.
Trying other mirror.
Error: Cannot open/read repomd.xml file for repository: livna
[root@localhost antti]#

Mandibela
10th August 2007, 07:13 PM
Solved: livna doesn't support fc8... yet

rvs1st
29th January 2008, 06:26 AM
http://lists.atrpms.net/pipermail/atrpms-users/2007-June/007424.html
from Sameer Lalwani

see second line: for [atrpms] and [atrpms-testing]


[atrpms]
name=ATrpms for Fedora Core $releasever - $basearch
baseurl=http://dl.atrpms.net/fc$releasever-$basearch/atrpms/stable
# The Fedora 7 version, so people stop emailing me about it
#baseurl=http://dl.atrpms.net/f$releasever-$basearch/atrpms/stable
enabled=1
gpgcheck=1
gpgkey=http://ATrpms.net/RPM-GPG-KEY.atrpms

[atrpms-testing]
name=ATrpms (testing) for Fedora Core $releasever - $basearch
baseurl=http://dl.atrpms.net/fc$releasever-$basearch/atrpms/testing
# The Fedora 7 version, so people stop emailing me about it
#baseurl=http://dl.atrpms.net/f$releasever-$basearch/atrpms/testing
enabled=0
gpgcheck=1
gpgkey=http://ATrpms.net/RPM-GPG-KEY.atrpms