PDA

View Full Version : Fedora 7 nvidia graphic driver keeps resetting



chuong
3rd June 2007, 06:44 AM
From big help of Firewing1 on #livna channel, I was able to get the 3D graphic driver working for my nvidia geforce 4 mx 440 graphics card using the nvidia-96xx driver.

I had to also changed a few files to get things working, such as the xorg.conf file found under /etc/X11/. I had to change the Driver "nv" to "nvidia". I did this with root, so any changes is permanent.

Then I also had to restart the nvidia driver service by typing service nvidia-96xx restart.

After that, I needed to type gdm-restart to log out and let the driver take effect. All cool so far.

When I logged in, the graphic driver is working, I have direct rendering and 3D acceleration support.

Then I restarted my computer. During the termination of process i.e. "sending all process the TERM signal" in the black and white screen, I noticed it also says "Disabling nvidia-96xx driver: [OK]"

After it booted Fedora 7 from the grub boot loader, and saying "Welcome to Fedora" on the black and white text screen, it once again, showed the lines:

cp: cannot stat 'nvidia0': permission denied
cp: cannot stat 'nvidia1': permission denied
. . .

I log into my account and try the driver, but the driver is not working again. I have to change the /etc/X11/xorg.conf again to Driver "nvidia" instead of "nv".

This is really starting to get annoying.

So I was wondering if anyone has gotten the 3D graphic driver nvidia-96xx to "stick" even after restart.

System:

Fedora 7
Geforce 4 MX440 with AGP8x.

Aresera
3rd June 2007, 06:58 AM
disable SeLinux and fireWall

Firewing1
3rd June 2007, 07:05 AM
Hello again :p
You mentioned that the driver disables on boot down, does the nvidia driver enable on bootup without errors?
@Aresera, disabling the firewall won't affect the nVidia driver at all, it will just make the system much less secure.
Firewing1

1yippy1
3rd June 2007, 07:26 AM
Hey Chuong I have a 440mx card with livna nvidia-96xx driver it works ok just I cant change my screen resolution without getting a scrambled screen, I did "rm /etc/udev/devices/*" which stopped "cp: cannot stat 'nvidia0': permission denied
cp: cannot stat 'nvidia1': permission denied" on boot up

sorry I also "gedit /etc/udev/makedev.d/60-nvidia.nodes" with

nvidia0
nvidia1
nvidia2
nvidia3
nvidiactl

Finalzone posted this somwhere on the forum

chuong
3rd June 2007, 07:52 AM
Yo Firewing1 !

It's chewedon here from #fedora and #livna haha.

Yeah, after getting the nvidia graphic driver working I rebooted the computer.

When I got back into Fedora after the reboot, it showed the:

cp: cannot stat 'nvidia0': permission denied

thing again.

I'm guessing that's an error on boot up.

I had to reconfigure the xorg.conf file again as well. Seems like the system just keeps overwritting the xorg.conf file everytime I reboot.

I'm currently on #fedora and #livna at the moment.

EDIT: I didn't see any lines that says "starting nvidia-96xx driver" during boot up.

You reckon I should do what 1yippy1 did ?

chuong
3rd June 2007, 12:52 PM
Firewing1, you there ?

Firewing1
3rd June 2007, 06:46 PM
I've noticed something wierd about the 9762 driver - After upgrading my 'nvidia' service wasn't set to run at startup.
What happens when you run:

chkconfig --list nvidia
Firewing1

chuong
4th June 2007, 04:53 AM
When I run chkconfig --list nvidia I get:

error reading information on service nvidia: No such file or directory

Firewing1
4th June 2007, 04:50 PM
I always forget, 96xx :rolleyes:

chkconfig --list nvidia-96xx
Firewing1

chuong
5th June 2007, 06:19 AM
[root@localhost ~]# chkconfig --list nvidia-96xx

service nvidia-96xx supports chkconfig, but is not referenced in any runlevel (run 'chkconfig --add nvidia-96xx')

Firewing1
5th June 2007, 01:11 PM
Now that's really odd.... Was this an upgrade install from FC5/6?
Either way, do
su -
chkconfig --add nvidia-96xx
chkconfig nvidia-96xx on
And all should be well.
Firewing1

chuong
5th June 2007, 01:45 PM
Yeah, it was an upgrade from Fedora Core 6, rather than a fresh install.

Lets hope it's all fixed this time.

chuong
5th June 2007, 01:52 PM
Impressive Firewing1, very impressive :)

Restarted, logged in and graphic driver works automatically without needing me to do anything.

Cheers.

Firewing1
5th June 2007, 02:54 PM
Glad things are working now - Just a note to other users if you're seeing the same problems after updating from FC5/6, please submit a bug at bugzilla.livna.org... This is the second time I hear of problems like this, I'm not sure if it's a coincidence or a bug in the package...
Firewing1

cr4ck3r
14th June 2007, 12:50 AM
I have the same problem, but I did a fresh install from the DVD. But it seems that I already have 3D enabled.
PS: After deleting the following files:
nvidia0
nvidia1
nvidia2
nvidia3
nvidiactl
in the /etc/udev/devices/, problem solved.
I think this is a bug of nvidia-96xx driver.