PDA

View Full Version : fedora 7 x86_64 and vmware 6



seeker010
3rd June 2007, 06:30 AM
having issues with vmware 6, it will randomly crap out and give me "vmware workstation internal monitor error"

anyone else experience this?

badbat75
4th June 2007, 10:47 AM
I have the same problem with VMware Server 1.0.3, same arch.

psyklops
4th June 2007, 02:55 PM
no issues here. running F7 on x86_64 with Vmware Workstation 6.0... what are the vmware logs saying?
have you got any errors in dmesg and var/log/messages?

badbat75
5th June 2007, 10:53 AM
I will try to post a Photo beacuse after the error the system hangs and I cannot do anything...

psyklops
5th June 2007, 11:52 AM
okay a couple of things.

Are you running x86_64 vesion of Fedora 7? Are you running x86_64 of VMware Workstation 6.0? Are you running latest kernel and latest update patches?

badbat75
5th June 2007, 06:59 PM
I'm running FC7 x86_64 with WMware Server v1.0.3 x86.
The system crash with x86 or x86_64 guest O.S. when it tries to start APIC.

badbat75
9th June 2007, 12:13 AM
This is the error!!!
Thank you for your help

psyklops
9th June 2007, 04:49 AM
haven't seen that one before.

you may want to head over to the VMware community forums and post your issue there. The VMware team monitor the forums and can assist.
http://www.vmware.com/community/index.jspa

badbat75
9th June 2007, 10:18 AM
Thank you, I'll keep you informed...
Bye

seeker010
9th June 2007, 10:18 PM
tentatively solved my problem by using noapic boot option. something must've changed in the way 2.6.21 handles interrupts, or x86_64 vs i386. My bios has that bug where the mp bios isn't connected to io-apic or whatever it was, but all was peachy under fc6-i386.

badbat75
11th June 2007, 04:15 PM
With noapic the system can't load some module like raid, usb... so I can't use it.
I think it is a bad implementation of the ACPI/APIC protocols... It is strange that with FC6 all worked well!!!

seeker010
12th June 2007, 12:35 AM
With noapic the system can't load some module like raid, usb... so I can't use it.
I think it is a bad implementation of the ACPI/APIC protocols... It is strange that with FC6 all worked well!!!
hmm I seem to have loaded the usb module just fine.

abiscula
14th June 2007, 04:15 PM
I am currently facing the same problem, has anyone found a good solution to make guest systems work with apic/acpi enabled?

badbat75
14th June 2007, 11:11 PM
with acpi_use_timer_override on guest and host kernel parameter i succeded to go to the grafical installation... then it crash... but I'm going on...
But the system now doesn't hang!!!
What are your chipset?
I've got a Nvidia 4 Professional 2200+2050.

badbat75
15th June 2007, 12:19 AM
Finally I succeded to make a complete installation!!!!

Try to use those parameters when booting linux kernel on your host OS.
acpi_use_timer_override irqpoll

cr22rc
15th June 2007, 02:15 AM
Sorry this isn't really vmware... but after several days of trying to get it to work on F7 x86_64 dual amd had no luck. Constant machine lockup when trying to install. Tried may of the options listed here with no better results. Was using latest free version server. Then stumbled on VirtualBox http://www.virtualbox.org/ Has an rpm for F7 http://www.virtualbox.org/download/1.4.0/VirtualBox-1.4.0_21864_fedora7-1.x86_64.rpm.run

Installed as easy as eating pie and ice cream :-) Running RH ES4 32bit guest. YMMV

badbat75
15th June 2007, 04:11 PM
Perfect :-(....
This morning I will try to start the system and it hangs....

So, anyone of that parameters is a solution...
So now I booted the kernel without values.
Now, I inserted this line in the .vmx file:

host.useFastClock = FALSE

And all seems to work!!!
Now I will make some tests!!!!

seeker010
14th July 2007, 09:42 PM
Perfect :-(....
This morning I will try to start the system and it hangs....

So, anyone of that parameters is a solution...
So now I booted the kernel without values.
Now, I inserted this line in the .vmx file:

host.useFastClock = FALSE

And all seems to work!!!
Now I will make some tests!!!!
sorry for bumping old post;

I tried this suggestion and so far no go..

have you had any further experiences?

abiscula
15th July 2007, 12:16 AM
I found one solution... Move back to fedora 6.... :( :( :( :( :( :( :( :( :( :( :( :(

badbat75
16th July 2007, 09:29 AM
Have U tried host.useFastClock on the vmx file and irqpoll as kernel parameter?
This is my configuration... The only problem I have, is a big clock skew on guest os....

Mortymer_84
16th July 2007, 03:46 PM
Have U tried host.useFastClock on the vmx file and irqpoll as kernel parameter?
This is my configuration... The only problem I have, is a big clock skew on guest os....
I have the same problem, i tried with the kernel parameter and nothing change, but when i use hostFastClock I stop to have error. Now my virtual appliance run, but when it try to get ip address it shutdown :mad: I hope it's a problem with the appliance, now i build one by myself ;)

Ps: I have a Intel Core due duo 6320, motherboard intel, Fedora 7 update this morning and vmware server with vmware-any-any-update110.

seeker010
17th July 2007, 10:23 PM
Have U tried host.useFastClock on the vmx file and irqpoll as kernel parameter?
This is my configuration... The only problem I have, is a big clock skew on guest os....
hey, I didn't see your older post.
acpi_use_timer_override irqpoll pci=routeirq fixed everything for me, so far.

remi
21st July 2007, 07:42 PM
Hi,

Good news : all seems to work fine with lastest kernel-2.6.22.1-27.fc7 without any workaround.

Remi.