PDA

View Full Version : Desktop effects could not be enabled



Graham1
2nd June 2007, 10:24 PM
Hi Guys

Just installed Fedora 7 and tried enabling desktop effects but I'm getting the following error:-

"Desktop effects could not be enabled"

I'm guessing I probably need to upgrade my graphic card drivers. My card is an Nvidia GeForce4 420 Go 32M. Any hints or tips?

Thanks

:)

Gnafu the Great
2nd June 2007, 11:12 PM
You'll need to install nVidia's prorietary drivers, which can be found on the Livna repository. And make sure you get the 96xx one, because your card is not supported in the newer 97xx driver (I, too, have a GF4).

leigh123linux
2nd June 2007, 11:24 PM
Try

su -
rpm -ivh http://rpm.livna.org/livna-release-7.rpm
yum install kmod-nvidia-96xx xorg-x11-drv-nvidia-96xx
nvidia-config-display enable
service nvidia restart

Graham1
3rd June 2007, 12:02 AM
Thanks guys, that did the trick.

Cheers

:)

rfair404
4th June 2007, 01:48 AM
I have tried to do something similar.
I have Nvidia 7800 GS. I am new to linux but I know pcs well. so if you can respond in "first grade English" I would appreciate it.

Anyways here is what happened. I installed Fedora 7 x86_64 on my Core 2 Duo system that I built. triple booted with XP and Vista. Everything went fine once I got grub installed in the right places. When I try to start desktop effects I get a message that says "Desktop Effects Can not be enabled"
I assume it is related to my video card. So... I download driver form Nvidia... started terminal went to root and tried to run the driver package, but it said no cc found in path, and While looking for a solution to that, I found the drivers at some other repos. and installed the nvidia driver from Livna. Seemed to be successful, but still can not start desktop effects.
Don't really know what to do from here.

Help pls.

theReaper
4th June 2007, 01:57 AM
i also can't start desktop effects, I have a geforce 7600gs and am using what I assume are the latest nvidia drivers from livna (as yum update kmod-nvidia tells me that I have the latest version)

help would be appreciated but desktop effects are really just decoration so no solution? no worries

strikeforce
4th June 2007, 02:18 AM
Make sure your nvidia drivers are working. Try



glxinfo | grep render


That will say whether you have glx working.

theReaper
4th June 2007, 02:26 AM
im a total linux n00b so, heres the output of that, advice?



[Dai@DADSPC-FEDORA7 ~]$ glxinfo | grep render
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
[Dai@DADSPC-FEDORA7 ~]$

strikeforce
4th June 2007, 02:31 AM
That's why. :)

http://fedorasolved.org/video-solutions/nvidia-yum-livna/

theReaper
4th June 2007, 02:37 AM
maybe i'm missing something here but that link seems to tell me what ive already done, or am i just being a dumbass?

strikeforce
4th June 2007, 02:40 AM
You might have the wrong driver for your card?

You might not have enabled the nvidia driver in your /etc/init.d?

I really don't know what you have done I'm tossing up suggestions to check. Maybe remove it and go through step by step cause you might have missed something.

rfair404
4th June 2007, 02:42 AM
when I try to start form terminal, I get this...

[root@localhost ~]# desktop-effects
gtk-window-decorator: Could not acquire decoration manager selection on screen 0 display ":0.0"
compiz: No GLXFBConfig for default depth, this isn't going to work.
compiz: Failed to manage screen: 0
compiz: No manageable screens found on display :0.0
[root@localhost ~]#

also-

[root@localhost ~]# glxinfo | grep render
direct rendering: No
OpenGL renderer string: Mesa GLX Indirect

theReaper
4th June 2007, 02:42 AM
nah i think i'll just give up, i dont play games on fedora anyway, thats what windows is for

strikeforce
4th June 2007, 02:50 AM
Yeah it seems that your glx is not enabled. So some how in the install you haven't enabled the nivdia glx which you need. As I mentioned have a look at the howto and work through it slowly. There are posts on the forums relating to installing it. Firewings posts and on his blog I think is updated to fedora 7.

theReaper
4th June 2007, 02:52 AM
OK, restarted to see if anything would change and X failed to start, in the output log it mentioned a version mismatch between X and the nvidia driver, X version was 1.0-9762 and nvidia 1.0-9755 so i will mess with it a bit more, see if i can get em to match

*edit

OK, I am such a moron, heres what you do, assuming that you have a fresh install of F7, sod the terminal, open the software installer and search available packages for kmod-nvidia, then choose the one which has 1.0.9762 and matches your kernel. if that even makes sense, basically I had the wrong version of the driver, it was mismatched with X and now I have wobbly windows (+ pic of boobs = endless childish laughter)

strikeforce
4th June 2007, 03:15 AM
rofl good work.

Scytale
4th June 2007, 05:42 AM
Also make sure SE-Linux is set to permissive and not enforcing, if it's set to enforcing X will bomb on the restart because SE-linux prevents the kernel module from being loaded.

strikeforce
4th June 2007, 06:38 AM
Not true Scytale. You can leave SELinux to enforcing and you should. There is a way to allow the driver to function even with the nvidia driver.

Set SEBool=1 or something like that.

There is a reference in my sig from fedora solved.

Scytale
4th June 2007, 06:46 AM
I had a brief look on that site couldn't find anything mentioning it, can you post a direct link, wouldn't be suprised if there was a workaround, setting to permessive and re-booting should allow you to confirm what the issue is anyway.

strikeforce
4th June 2007, 06:53 AM
http://www.linuxmanpages.com/man8/setsebool.8.php
http://www.fedoraforum.org/forum/showthread.php?t=99285



#setsebool -P allow_execmod=1
#service nvidia-glx restart


Those are the commands if you have issues with SELinux. I think the livna packages sorts that out but I could be wrong. I haven't had SELinux issues for awhile.

Scytale
4th June 2007, 06:56 AM
I had problems with it in Test 3 and 4 haven't enabled Nvidia driver it in 7 yet. I'll run an experiment tonight and see what happens

strikeforce
4th June 2007, 07:05 AM
Post back as a reference for other people if you can I would be interested since I have a computer that has an nvidia card as well. I haven't upgraded yet.

My laptop has an ati x1300 which doesn't work yet waiting for the new drivers but yeah other than that and wireless I'm happy.

Scytale
4th June 2007, 07:13 AM
according to the guide at mjmwired.net the SE linux bug still persists. He's fix is:

sudo /usr/bin/chcon -cv system_u:object_r:xserver_misc_device_t /etc/udev/devices/nvidia*

http://www.mjmwired.net/resources/mjm-fedora-f7.html

I'll post back tonight.

Yeah my laptop has an ATI mobility something or rather in it (It's a Macbook Pro) my next experiment is to set up a Fedora OSX dual boot should be interesting last time I tried grub killed the EFI boot partition and had to run the OSX recovery DVD just to get the laptop to boot :(

Scytale
4th June 2007, 12:05 PM
Well it seems to be working I was running in Permissive mode installed module, switched to Enforcing rebooted and everything works fine, didn't need to make any extra changes, perhaps the drivers have been updated to fix the se linux issue

[Matthew@localhost ~]$ glxgears
51677 frames in 5.0 seconds = 10335.247 FPS
51803 frames in 5.0 seconds = 10360.525 FPS
51813 frames in 5.0 seconds = 10362.447 FPS
51819 frames in 5.0 seconds = 10363.672 FPS

rfair404
4th June 2007, 01:05 PM
Yeah it seems that your glx is not enabled. So some how in the install you haven't enabled the nivdia glx which you need. As I mentioned have a look at the howto and work through it slowly. There are posts on the forums relating to installing it. Firewings posts and on his blog I think is updated to fedora 7.

so if I understand you correctly, this is a step additional to simply installing the driver. Does anyone know of any good how to's when it comes to enabling the glx?

mjmwired
4th June 2007, 01:28 PM
according to the guide at mjmwired.net the SE linux bug still persists. He's fix is:

sudo /usr/bin/chcon -cv system_u:object_r:xserver_misc_device_t /etc/udev/devices/nvidia*

http://www.mjmwired.net/resources/mjm-fedora-f7.html

I'll post back tonight.

This should have been fixed by the update made available on June 2, by livna.
# yum update nvidia-kmod

Quadcore
4th June 2007, 03:29 PM
Woohoo I did the YUM update and my desktop effects work..