PDA

View Full Version : F7 Cannot mount volume... when CD is inserted...



HMSS013
2nd June 2007, 09:49 PM
Error org.freedesktop.Hal.PermissionDenied.

Permission Denied: Not in active session.

WTF?!!?!? this never happened in FC6...

i've been using super user to mount the drive... but its a pain...

mikelat
3rd June 2007, 06:23 AM
Same issue, except with an external hard drive (FAT32). The strange part is, it used to work fine when I started using FC7 yesterday, but just today it has this error now.

kanenas
3rd June 2007, 06:49 AM
Hi,

I had the same issue (Permission Denied: Not in active session.) and it was solved by restarting the ConsoleKit service and logout-login.
I hope that helps.

Seve
3rd June 2007, 06:51 AM
Hello:
Check you system-config-services and make sure you have ConsoleKit enabled

I had the same issue /same error and for whatever reason I selected ConsoleKit and restarted the service, then rebooted and then I was then able to auto mount USB drives and Media again ..... dunno why ?
I can only guess it has to do with sessions ??

Seve

mikelat
3rd June 2007, 07:14 AM
Hi,

I had the same issue (Permission Denied: Not in active session.) and it was solved by restarting the ConsoleKit service and logout-login.
I hope that helps.
Worked perfectly! Thank you very much!

al_nn
7th June 2007, 05:21 AM
The same trouble for me :( But i'm using KDE - restarting ConsoleKit and logout/login doesnt help ;(
In Gnome session all works fine, btw..

kanenas
7th June 2007, 06:18 AM
Strange,

I am using KDE also. In fact I installed fedora 7 from the KDE live-cd. Have you configured KDE to save and restore the previous sessions ? (although I am not sure that this is what is wrong). You can do that with Menu - Control Center - KDE Components - Session Manager there you check "On Login - Restore Previous session".
I hope this will solve the problem (but it is only a guess).

mvssarma
7th June 2007, 09:24 AM
Hello:
Check you system-config-services and make sure you have ConsoleKit enabled

I had the same issue /same error and for whatever reason I selected ConsoleKit and restarted the service, then rebooted and then I was then able to auto mount USB drives and Media again ..... dunno why ?
I can only guess it has to do with sessions ??

Seve

Hi, Iam relatively new to this OS. please help me with little more clarification, so that i could also enjoy this facility

mvs_sarma@yahoo.com

al_nn
8th June 2007, 05:24 AM
Have you configured KDE to save and restore the previous sessions ?
Bug still persists - when I'm enable this settings, and when disable, I still cannot mount my dvd's :(
My install was an upgrade from Fedora-6 by full F7 DVD.
On bugzilla (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=242882) I have only 1 response.. :(

Seve
8th June 2007, 05:31 AM
Hi, Iam relatively new to this OS. please help me with little more clarification, so that i could also enjoy this facility

mvs_sarma@yahoo.com
Hello:
If you open a terminal, then copy and paste
system-config-services
you will be prompted for your root password, enter that, then you will see the service(s) as previously described.

Follow the instructions from there and you will be fine.

Seve

yemmi
11th June 2007, 09:58 AM
i have the same problem!
i i use mount on consolle it works good, but if i try to mount dvd or something in kde i see that message
"Permission Denied: Not in active session"

i have fedora 7 upgraded from fedora core 6 by dvd

starting o restrating consolekit and/or reboot didn't work :/

yemmi
11th June 2007, 10:17 AM
ok maybe solved...
now it works

consolekit activate
and i've added this line on /etc/fstab for the dvd player:


/dev/scd1 /media/dvd/ iso9660 defaults,ro,user,noauto 0 0

that is my dvd device (/dev/scd1) and a folder that i've created (/media/dvd) to mount all dvd in an unique folder

and now all devices works (dvd, dvdrecorder, usb sticky, etc..)

hope can help you

Jongi
1st July 2007, 09:31 PM
I'm having the same problem with KDE ("Permission Denied: Not in active session") and a usbstick. What fstab options fstype and the ones that follow should I use?

EDIT: Here's the solution for a usbstick



# su -
# mkdir /media/usbstick
# chmod 755 /media/usbstick
# vi /etc/fstab

Enter the following into fstab


/dev/partition /media/usbstick auto noauto,user 0 0

a_m0d
30th August 2007, 10:48 PM
I have the same problem but in Fedora Core 6, and I don't have a consolekit service listed in system-config-services. I can't find one in the update, remove, or install view of yum extender, either. This problem only just started the other day, and now I can't auto-mount anything!

uchar_t
13th October 2007, 10:04 AM
I had the same problem of "Permission Denied: Not in active session" when my USB is inserted.

When I restart ConsoleKit Service and Logout/Login, the problem is gone for good.

jeanfiga
28th November 2007, 10:12 PM
I had the same problem of "Permission Denied: Not in active session" when my USB is inserted.

When I restart ConsoleKit Service and Logout/Login, the problem is gone for good.

Same here. I'm using kde and fc7. I checked the box and started ConsoleKit, made sure to click the "save" button before exiting the services application. The did the log in log out and I can mount volumes from konqueror.

Nice, thanks guys.

--Figa