PDA

View Full Version : nautilus hides /dev/sd* drives from Places



stas.lyahnovich
2nd June 2007, 03:22 PM
Hello, does anyone know why nautilus hide /dev/sd* (my SATA drives) devices from Places.
this is section from my /etc/fstab

/dev/sdb6 swap swap defaults 0 0
/dev/sdb8 /mnt/e ntfs noauto,ro,user,umask=0 0 0
/dev/sdb1 /mnt/h ntfs noauto,ro,user,umask=0 0 0
/dev/mapper/nvidia_dfjgiheep2 /mnt/j ntfs noauto,ro,user,umask=0 0 0
/dev/sdb10 /mnt/fat vfat user,umask=0000 0 0
Nautilus show 'j' drive in Places section but hides other.

When i trying to write

/dev/fd0 /mnt/e ntfs noauto,ro,user,umask=0 0 0
it show drive 'e' in places
when i write (there is now /dev/sdb15 node) like this

/dev/sdb15 /mnt/e ntfs noauto,ro,user,umask=0 0 0
dev/sdb8 /mnt/e ntfs noauto,ro,user,umask=0 0 0

when it point to not exisiting nodes it show letter 'e' in places section
but when i point to real sdb partition it hides device from places
but some how it shows

/dev/mapper/nvidia_dfjgiheep2 /mnt/j ntfs noauto,ro,user,umask=0 0 0
as letter 'j'
Any guesses?
I'm using Fedora 7 the problem was in Fedora Core 6 too.

And there is also a problem when i'm triyng to mount any drive as ordinary user (not root), when i'm runnig mount /mnt/e it does nothing and display no errors. When it'm try as root it works. I have option 'user' for all my drives but it seems mount ignore it, but if i remove this option mount display an error ' only root can mount'. this fstab work fin in FC6. The problem appears in FC7

Dies
2nd June 2007, 09:42 PM
http://forum.fedoraforum.org/forum/showthread.php?t=151553

stas.lyahnovich
3rd June 2007, 05:19 PM
OK Thank you...
But what with mount problem..? As i detected mount works fine with FAT32 partition, but returns code 1 when i try to mount NTFS partition.

Dies
3rd June 2007, 05:30 PM
Use ntfs-3g as the file system type instead of ntfs, and if you want write access then leave the ro out.

stas.lyahnovich
4th June 2007, 06:16 AM
Use ntfs-3g as the file system type instead of ntfs, and if you want write access then leave the ro out.
Nothing changed... it seem there is permission problem with mount

stas.lyahnovich
4th June 2007, 12:36 PM
The problem described here...
http://www.ntfs-3g.org/support.html#useroption2
but why it works fine in FC6