View Full Version : How to start fresh copy of Yum for Fedora 7 ?

2nd June 2007, 10:09 AM
Hello guys.

I just upgraded my Fedora Core 6 to Fedora 7.

I had to reinstall the linux graphic driver kmod-nvidia-96xx but when I tried to use the yum command to install it, yum gave me an error:

Error: Cannot open/read repomd.xml file for repository: updates

So I tried to start fresh by typing:

rm -rf /etc/yum.repos.d/*

That's where I am currently.

How do I install the livna repos etc ?

My apologies if this topic has already been started.


Fedora 7
Nvidia Geforce 4 MX 440

2nd June 2007, 11:27 AM
How do I install the livna repos etc ?

From a terminal logged in as root
rpm -Uvh http://rpm.livna.org/livna-release-7.rpm

You also may want to have a look here for some guidance on switching repos for F7
The guide is for FC6, but I believe the same concept applies
Yum Upgrade FAQ (http://fedoraproject.org/wiki/YumUpgradeFaq)



2nd June 2007, 02:51 PM
Uh yeah, cool.

I've updated my system fully now.

The only thing I'm trying to get working is the Nvidia graphic driver.

My graphics card is Nvidia Geforce 4 MX440 with AGP8x.

I've installed kmod-nvidia-96xx but it still says direct rendering: No.

Some guys recommended I do MAKEDEV nvidia and after doing that, every program that requires 3D graphic acceleration kicks me out of my current session.

I was told SELinux is preventing nvidia from creating some files or something.

Any idea how to fix my graphic driver without making system keep crashing ?

2nd June 2007, 04:11 PM
Oh, yeah cool.

Firewing1 on #livna channel helped me fixed the driver problem.

Need to install his new build thing.