PDA

View Full Version : alsamixer still does not work for me in F7!



joe.pelayo
2nd June 2007, 06:12 AM
Hello everybody.

Today I downloaded and installed F7 in my laptop, hopping among many things that it would finally solve the issue FC6 has with alsamixer and therefore with the keyboard shortcuts related to volume.

In F7 I get the same error:

[joe@localhost ~]$ alsamixer

alsamixer: function snd_mixer_load failed: Invalid argument
[joe@localhost ~]$

Trying to fix it I decided to install more alsa libs, no luck; reconfigured the sound card, no luck; used a strange script in the modprobe.conf file, no luck

# load/unload the volume settings on startup/shutdown
install snd-hda-intel /sbin/modprobe \
--ignore-install snd-hda-intel;/usr/sbin/alsactl restore
remove snd-hda-intel /usr/sbin/alsactl \
store;/sbin/modprobe --ignore-remove -r snd-hda-intel
I think I have two remaining options: try to configure alsa myself (perhaps editing some files) or recompiling the kernel.

My first option seems to be quite easy to do provided that my sound card is well supported by ALSA, I know that because in both Ubuntu and PCLinuxOS it works as expected. Here arises my first question: which configuration files should I 'copy' from, say Ubuntu, to FC7 to make ALSA work?

While I am writing this post another Linux kernel is being compiled (option 2), hopefully this solves the problem but if it does and I choose to keep it...
will it generate problems to install stuff (mostly drivers) from repositories like Livna for example?
I followed a guide http://www.howtoforge.com/kernel_compilation_fedora_p2 to compile the kernel from which I understand the resulting kernel is quite compatible with my current running kernel (a 'Fedora official one'). Is there a way to fool the packaging system so it thinks my slightly customized kernel is an 'official one'?

Thanks.
Joe.

joe.pelayo
2nd June 2007, 04:44 PM
It seems I am the only one with this problem. Yesterday I installed in the laptop Debian 4.0, it did not have this ALSA problem but was unable to enable cpufreq.

I think I will replace FC6 with PCLinuxOS 2007.

Joe.

pikul
2nd June 2007, 11:37 PM
Same here, in Ubuntu works just fine without any tweaks, on fedora 7 its not working :(

joe.pelayo
3rd June 2007, 09:09 AM
Same here, in Ubuntu works just fine without any tweaks, on fedora 7 its not working :(
It would be interesting to identify the devices affected by this. Mine is an integrated Realtek sound card (tomorrow when I use the laptop will post its specs) identified as snd-hda-intel (something like High Definition Audio).
Joe.