PDA

View Full Version : gimpShop



kalaka
2nd June 2007, 04:14 AM
Hi, I'm riunning Fedora 6 and I've been trying to install gimpShop. To be honest, its been a pain in the ass.
There are no RPMs (not for Fedora anyway). I figured the only way to install it is from source. First of all, it can't be compiled with GCC 4.1 so I installed compat-gcc-34 and compat-gcc-34-c++ through yum. It needs GLib 2.4.5 or newer. The latest GLib found through RPMs is 1.2.10 so I have to install that from source, too. I successfully install GLib 2.6.6 but when I try to run ./configure --prefix=/usr CC=gcc34 CXX=g++34 to install gimpShop from source I get the following message:


checking for GLIB - version >= 2.4.5...
*** 'pkg-config --modversion glib-2.0' returned 2.6.6, but GLIB (2.12.9)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error: Test for GLIB failed. See the file 'INSTALL' for help.


I already removed the old version of GLib by running rpm -e glib --nodeps (is that dangerous?) but it still doesnt work. Does anyone has any suggestions? Has anyone successfully installed gimpShop in Fedora?

kalaka
3rd June 2007, 10:41 PM
I'm sorry to bump the thread but I'm really desperate here. Anyone got any ideas?

bob
3rd June 2007, 11:13 PM
I have no programming skills but I did notice that Glib2.i386 with version 2.12.11-1.fc7 is listed for Fedora6 (I'm in that right now and did 'yum --enablerepo=development search glib" to get it). That might work for you.

kalaka
4th June 2007, 06:41 AM
I'm sorry Bob, but I need GLib 2.4.5 or newer (you suggested 2.12.11). It doesnt matter though, I managed to install GLib from source, but now I'm having problems installing gimpShop again. I'm trying to install Gtk+ (2.6.10) from source because its one of the dependencies (and no, there are no rpms). When I try to run ./configure it says:

configure: error: Xft Pango backend is required for x11 target

I installed pango and freetype (for freetype I used rpms).
[root@localhost ~]# pkg-config --list-all | grep freetype
freetype2 FreeType 2 - A free, high-quality, and portable font engine.
[root@localhost ~]# pkg-config --list-all | grep pango
pango Pango - Internationalized text handling
pangoft2 Pango FT2 - Freetype 2.0 font support for Pango

Isn't there a simpler way to install this? Can someone please make a bloody RPM?

strikeforce
4th June 2007, 06:48 AM
You are going to break your system if you start mixing stuff.



yum search blah

kalaka
4th June 2007, 07:19 AM
You are going to break your system if you start mixing stuff.



yum search blah

Didn't you read what I said in the first post? There are no RPMs.

strikeforce
4th June 2007, 07:29 AM
I read your post.

http://linux.suramya.com/tutorials/Install_GIMPShop/

Have you tried to look at the very bottom of this post.

Google is amazing sometimes.

kalaka
4th June 2007, 07:33 AM
That RPM doesnt work for Fedora. Do you think I haven't looked? Do you think I've been installing all kinds of stuff from source for fun? This is driving me insane! And I don't even care that much about the program.

Forget it. Even though I managed to install GLib, atk, pango and libtiff from source, I still can't compile Gtk+ because it says I'm missing the X development libraries and something about missing the Pango Xft backend. This is just impossible, Fedora is wired differently. There must be a reason there are no RPMs. It's just not worth it.

Thanks, though

bob
4th June 2007, 11:29 AM
Unfortunately, that may be the reason there are no rpms; too many interlocked dependencies. And, you've just been through 'dependency hell', unfortunately installing some packages that might interfere with other packages down the line. Not everything works for every distro; too many forks in the linux road, I'm afraid. And, not that it matters anymore, but last I looked "12" is greater than "4" :D )