PDA

View Full Version : Fedora 7 Mouse and video Problems



mhbell
2nd June 2007, 03:56 AM
Fresh Install of Fedora 7 Compaq Presario SR2039X AMD 64 with Nvidia Chipset and Nvidia 6150 Built in Graphics card. 2 GB DDR Ram
Downloaded DVD X86-64 Fedora 7 release.

Had to use (noapic) to install. Install went smooth with no problems Until 1st reboot.


Problem #1
No Mouse Cursor. The mouse is there because the Icons flash when the mouse passes over them. Also I can left click on an Icon and it will work. But still no cursor can't see where the mouse is.

The Mouse Problem is solved. I added a line in the Xorg.conf in the video section below driver nv
Option "HWCursor" "false" and now I can see the mouse cursor. Now to install the Nvidia drivers


Problem #2
The Resolution is 800x600 and cannot be changed with the desktop app. It is using the nv drivers which is for older cards. I am using the Gnome Desktop. The Mouse is a USB Mouse.

Any Help or advise would be appreciated.
Tia
Mel
:confused:

cr4ck3r
2nd June 2007, 12:27 PM
I have the same problem#1, but it happens sometime, not always. After digging more, it seems that the mouse device is not created in the xorg.conf file. It's weird because I happen randomly, not always.
PS: My mouse is a PS/2 mouse.

cr4ck3r
3rd June 2007, 04:35 PM
mhbell, could you please post your xorg.conf file? I'm still searching for solution for my mouse problem.

mhbell
3rd June 2007, 06:37 PM
Here you go The line under the vid card (Option "HWCursor" "false") did the trick.
Mel
:)

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib64/xorg/modules"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"Op
Option "HWCursor" "false"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

ThinkOpen
4th June 2007, 05:38 AM
I have a HP Pavilion Slimline s3000e that also has a AMD chip and probably the same Nvidia motherboard with a 6150LE integrated video card. Did you find out how to install the Nvidia drivers and change the resolution from 800x600?

mhbell
4th June 2007, 06:57 AM
I have a HP Pavilion Slimline s3000e that also has a AMD chip and probably the same Nvidia motherboard with a 6150LE integrated video card. Did you find out how to install the Nvidia drivers and change the resolution from 800x600?
Yes I installed the Nvidia drivers from the Livna repos got 1280 x 1024 now.
Mel
:cool:

ThinkOpen
4th June 2007, 07:15 AM
What repo do I need to add to install the nvidia drivers from Livna?

mhbell
4th June 2007, 04:32 PM
You will have to do a search for a how to install the Nvidia drivers. Thats what I did. There is a very good tutorial on someones blog don't remember the URL or name. here is some info that may help..
Mel
:)

I found the info. go to the below URL's the one is a blog by Stewart Adam and tells how to do it.
http://www.diffingo.com/blog/content/view/32/33/

http://forums.fedoraforum.org/showthread.php?t=99285


su -
rpm -Uhv http://rpm.livna.org/livna-release-7.rpm
yum install kmod-nvidia xorg-x11-drv-nvidia xorg-x11-drv-nvidia-libs-32bit
yum update kmod-nvidia xorg-x11-drv-nvidia xorg-x11-drv-nvidia-libs-32bit
service nvidia restart

cr4ck3r
7th June 2007, 03:56 PM
Here you go The line under the vid card (Option "HWCursor" "false") did the trick.
Mel
:)

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib64/xorg/modules"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"Op
Option "HWCursor" "false"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
Problem solved here!
Thanks mhbell!

MitchLoft
7th June 2007, 04:16 PM
This got the current nvidia drivers loaded on my system:

su -
rpm -Uhv http://rpm.livna.org/livna-release-7.rpm
yum install kmod-nvidia xorg-x11-drv-nvidia
yum update kmod-nvidia xorg-x11-drv-nvidia (this is a precaution - didn't find any updates at the time I did it)

Then I rebooted - resolution issues solved. I -DID find a need to turn off the hardware cursor as described above also, though.

MrNovi
8th June 2007, 01:02 AM
Okay, care to explain to a Linux newbie how you get to that file to change it when you don't have a functioning mouse?

mhbell
8th June 2007, 01:53 AM
I am not trying to be smart or a wise guy But you use the keyboard and the mouse. The mouse in my case works I just could not see the cursor. when the mouse was dragged over a Icon the icon would be hilited. also when the left mouse button was depressed and the mouse was dragged across the screen you could see a line and use that and the keyboard to get to where you wanted.

A better and faster way is to use the console or terminal using VI or some other editor to edit the file from the console.
Mel

MrNovi
8th June 2007, 02:30 AM
I am not trying to be smart or a wise guy But you use the keyboard and the mouse. The mouse in my case works I just could not see the cursor. when the mouse was dragged over a Icon the icon would be hilited. also when the left mouse button was depressed and the mouse was dragged across the screen you could see a line and use that and the keyboard to get to where you wanted.

A better and faster way is to use the console or terminal using VI or some other editor to edit the file from the console.
Mel

Okay, but that still doesn't explain how to fix the problem. I don't know where the file is that I need to edit. And yeah, IF, and that's abig if, you are lucky enough to drag the invisible curser over an icon it will highlight it, but who want's to waste time doing it that way. As for holding down the left button, again, that doesn't SOLVE THE PROBLEM.

Please remember that not everyone is a L:inux Guru. I'm VERY new to Linux and have no idea where the file I need to change is and without a FUNCTIONING mouse (and hunting and waiting for something to highlight and holding down the left button does not create a FUNCTIONING mouse) finding it is all but impossible. And I have no idea how to use "VI" to do anything.

wintersm
8th June 2007, 02:34 AM
ok - heres a way to use hardware mouse with a nvidia card..

disable rhgb - the graphical boot so

edit /etc/grub.conf (eg as root do a vi /etc/grub.conf)
and remove the mention of rhgb from the kernel line..

you wont have that fancy graphical boot (its only eye candy anyway and is of no actual use) but the hard ware cursor works..

This was discussed ages ago, it something to do with the nvidia driver and when rhgb terminates and the gui starts..

:)

MrNovi
8th June 2007, 02:38 AM
ok - heres a way to use hardware mouse with a nvidia card..

disable rhgb - the graphical boot so

edit /etc/grub.conf (eg as root do a vi /etc/grub.conf)
and remove the mention of rhgb from the kernel line..

you wont have that fancy graphical boot (its only eye candy anyway and is of no actual use) but the hard ware cursor works..

This was discussed ages ago, it something to do with the nvidia driver and when rhgb terminates and the gui starts..

:)


Care to explain that in NEWBIE speak? I have absolutely no idea how to do anything you just told me to do

mhbell
8th June 2007, 07:45 AM
The paths to the files that you want to edit are as follows

to edit the grub.conf: Path" /etc/grub.conf" without the quotes

to edit xorg.conf: Path "/etc/x11/xorg.conf" Without the quotes

You will need to get to a terminal or console

you will need to learn how to use the vi editor

I would suggest that you use a good vi tutorial. There are several good ones for someone who is just getting started. Check out this link. click here for tutorial[/URL

Here is a tutorial on the terminal/console [URL=http://forums.scotsnewsletter.com/index.php?act=ST&f=14&t=503&st=11]click here (http://forums.scotsnewsletter.com/index.php?act=ST&f=14&t=503&st=213)

here is an example of what it will look like in a terminal or the console
[mel@localhost ~]$ su (enter)
Password: xxxxxxxx (enter)
[root@localhost mhbell]# vi /etc/grub.conf (enter)

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,9)
# kernel /vmlinuz-version ro root=/dev/sda12
# initrd /initrd-version.img
#boot=/dev/sda10
default=0
timeout=5
splashimage=(hd0,9)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.21-1.3194.fc7)
root (hd0,9)
kernel /vmlinuz-2.6.21-1.3194.fc7 ro root=LABEL=/ noapic rhgb quiet
initrd /initrd-2.6.21-1.3194.fc7.img

~
"/etc/grub.conf" 20L, 642C

The rhgb in red is what you would remove.
Hope this helps you. For a real friendly helpful bunch you may want to try the ATL Forum
click here for ATL (http://forums.scotsnewsletter.com/index.php?showforum=14)
Mel