PDA

View Full Version : Can't disable Fedora 7 auto-suspend



lemaymd
2nd June 2007, 02:14 AM
I just installed Fedora 7 on my AMD64 X2. Unfortunately, it now automatically hibernates or suspends after some time and I can't stop it from doing so. Originally, the system hibernated automatically, but when I switched the "When the power button is pressed" option on the "Power Management Preferences" system applet to "Suspend", it started to suspend automatically. So, it stands to reason that switching to the "Ask me" option would cause the system to not suspend or hibernate automatically, and that did in fact work for my other machine, a Core 2 Duo. Unfortunately, my AMD64 system still suspends automatically. The "On AC Power" settings are to put the display to sleep after 30 minutes and put the system to sleep never. Any ideas? Thanks!

Jahova
2nd June 2007, 07:54 AM
bios settings?

lemaymd
2nd June 2007, 05:05 PM
OK, I figured it out. I had to use the Gnome Configuration Editor to edit the appropriate settings in the apps/gnome-power-manager group. They're fairly self-explanatory. Apparently the actual applet doesn't handle them properly yet.