PDA

View Full Version : canīt update firefox + yelp



Martin Pail
1st June 2007, 10:27 PM
hi to all,

canīt update to firefox and yelp because yum tells me
# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package firefox.i386 0:1.5.0.12-1.fc6 set to be updated
---> Package yelp.i386 0:2.16.0-13.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: firefox = 1.5.0.10 for package: gnome-python2-gtkmozembed
--> Processing Dependency: firefox = 1.5.0.10 for package: Democracy
--> Finished Dependency Resolution
Error: Missing Dependency: firefox = 1.5.0.10 is needed by package gnome-python2-gtkmozembed
Error: Missing Dependency: firefox = 1.5.0.10 is needed by package Democracy

any idea ?

thanks

kind regards

martin

Dies
2nd June 2007, 12:24 AM
Yup, it's pretty simple, either keep the conflicting packages and don't update or remove the conflicting packages and get your update.

If you just want the newer firefox you can always DL the official version and run that alongside. ;)

crolma4
2nd June 2007, 06:20 AM
I have the same problem, if I do
$ rpm -q firefox
I see
firefox-1.5.0.10-6.fc6
which I thought might somehow count as being the same as firefox 1.5.0.10
Is this something I should remove?
I can't even upgrade the kernel because swfdec-mozilla somehow needs 1.5.0.10.
Gee, Help->About Mozilla Firefox says
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.10) Gecko/20070510 Fedora/1.5.0.10-6.fc6 Firefox/1.5.0.10

which makes me wonder what my sin was.

Dies
2nd June 2007, 02:06 PM
which makes me wonder what my sin was.

I guess it was installing swfdec-mozilla. ;)

argus2
2nd June 2007, 03:46 PM
I just installed firefox 2.0.0.4 using http://remi.collet.free.fr/index.php?2007/06/01/363-firefox-2004-1
remi has versions for fc4, 5 and 6. I installedthe FC4-version using webmin, no problem at all

maybe this can be usefull for you

jonathonp
3rd June 2007, 06:21 AM
Fire fox update 1.5.0.12-1.fc6. remove packages that conflict with the new version like swfdec-mozilla from nvida (flash) or swfdec from freshrpms.

yum remove swfdec-mozilla

Once installed, open firefox and go to adobe flash test and simply click on the 'find plugin' to install flash. 3rd party repository is no longer needed.

http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=tn_15507

If your want install the firefox 2.0.0.4 (with spell check) you have to remove your fedora firefox version.

yum remove firefox

Once you download use the software installer for installation.

http://remi.collet.free.fr/index.php?2007/06/01/363-firefox-2004-1

You can also download firefox.i386 0:2.0.0.4-1.fc8 from the fedora development repository although i could not install the GPG key for some reason. i used yum extender to get around it. So far everything is working ok. i will be holding back from fedora 7 until the amd proprietary driver is available from livna.


http://www.michaellarabel.com/index.php?k=blog&i=224

crolma4
5th June 2007, 08:00 AM
Well. you guys called it right. swfdec-mozilla was the problem. It never seemed to work very well anyway. Getting rid of it made everything work.

I've placed my faith in tools like yumex because I don't want to relive the dependency hell I experienced before fedora started up. (I stick to fedora core + extras and livna.) But I never had a problem with browser updates, themes, or plugins. So I'll go off the ranch in this case. Thanx.