PDA

View Full Version : Console Resolution



elliottuk
1st June 2007, 09:37 PM
Hi,

Is anyone else having issues changing the res of console. i.e. runlevel 3?

I have added vga=0x317 to my grub config but it's not working.
I have also tried vga=791

This was just fine on FC6.

Any ideas?


I also have the same issue with Centos5. Was ok on 4.

Please help it's doing my head in!!!!

Thanks.

Bak
1st June 2007, 09:55 PM
Just checked mine, works just fine for me, replaced rhgb with vga=791

elliottuk
1st June 2007, 10:10 PM
AAGHH!!

This is my /boot/grub/grub.conf
(below)
Does it look correct?

I have tried editing with vi, nano, gedit (in case one was messing the lines up).
It just ignores me. The runlevel entry works though?

Can anyone think of what i could be doing wrong? it's clearly me. but what!?


# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,1)
# kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
# initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=5
#splashimage=(hd0,1)/grub/splash.xpm.gz
#hiddenmenu
title Fedora (2.6.20-2925.9.fc7xen)
root (hd0,1)
kernel /xen.gz-2.6.20-2925.9.fc7
module /vmlinuz-2.6.20-2925.9.fc7xen ro root=/dev/VolGroup00/LogVol00 3 vga=791 quiet
module /initrd-2.6.20-2925.9.fc7xen.img
title Fedora-base (2.6.21-1.3194.fc7)
root (hd0,1)
kernel /vmlinuz-2.6.21-1.3194.fc7 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.21-1.3194.fc7.img
title Other
rootnoverify (hd0,0)
chainloader +1

elliottuk
4th June 2007, 09:19 AM
Ok.

Turns out vga=791 et all won't work when your calling the Xen modules.

I have removed Xen features from my system all together and it's fine.

RRRuuuuuubbbissshhH!!!!