PDA

View Full Version : Postfix and vm-3dpop woes



TVYack.com
1st June 2007, 07:42 AM
Hey guys,

I installed postfix today via yum install postfix, then grabbed an rpm of vm-3dpop for my pop server.

I followed the instructions at: http://www.sonicresolutions.com/tech/howto_postfix_vmpop3d.html

Both installs went without issue, and I got everything in postfix configured correctly (I believe).

The issue is, both ports are reachable and postfix is supposedly delivering mail, however when I attempt to retrieve it using outlook I get no mail. Looking at my /var/log/maillog I get the following:


May 31 20:29:47 reverse58 postfix/qmgr[14298]: 2C1BA536829A: from=<lxmxfxd@gmail.com>, size=1917, nrcpt=1 (queue active)
May 31 20:29:47 reverse58 postfix/virtual[14416]: 2C1BA536829A: to=<jacki@skinfiles.com>, relay=virtual, delay=0.22, delays=0.16/0/0/0.06, dsn=2.0.0, status=sent (delivered to mailbox)
May 31 20:29:47 reverse58 postfix/qmgr[14298]: 2C1BA536829A: removed


May 31 20:31:15 reverse58 vm-pop3d[14368]: Unable to use jacki's mailbox; using
/dev/null for testing
May 31 20:31:15 reverse58 vm-pop3d[14368]: User 'jacki' of 'skinfiles.com' logge
d in from 72.177.83.158
May 31 20:31:15 reverse58 vm-pop3d[14368]: Session ended for user: jacki of skin
files.com from 72.177.83.158

I may be wrong, but I am interpreting this to mean that postfix is configured correctly, but vm-pop3d isn't, and vm-pop3d is deleting the mail by sending it to /dev/null.

If someone actually uses vm-pop3d here still (its quite old apparently) please point me in the right direction!

However, if someone has another solution for pop mail that would be better, please point me in that direction. Any HOW-TOs would be quite helpful too.

Thanks!