PDA

View Full Version : Yum - Package not signed. Fedora 7



The_Jaymz
1st June 2007, 04:30 AM
Clean install. first thing I do is yum update. I get this error:

Package libwnck-2.18.2-1.fc7.i386.rpm is not signed

Anyone know what's going on?

charlie_D
1st June 2007, 04:36 AM
I had the same problem, a 'yum update' from the terminal works fine though.

Not immensely helpful I suppose, but I have nothing else that needs updating after that :p

Charlie

The_Jaymz
1st June 2007, 04:38 AM
I ran it from the command line. Still no dice.

The_Jaymz
1st June 2007, 04:39 AM
Here's the actual output:

[root@JMH-LINUX ~]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package libwnck.i386 0:2.18.2-1.fc7 set to be updated
---> Package firefox.i386 0:2.0.0.4-1.fc7 set to be updated
---> Package mutt.i386 5:1.5.14-4.fc7 set to be updated
---> Package libexif.i386 0:0.6.15-1.fc7 set to be updated
---> Package yelp.i386 0:2.18.1-4.fc7 set to be updated

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Updating:
firefox i386 2.0.0.4-1.fc7 updates 21 M
libexif i386 0.6.15-1.fc7 updates 229 k
libwnck i386 2.18.2-1.fc7 updates 193 k
mutt i386 5:1.5.14-4.fc7 updates 1.5 M
yelp i386 2.18.1-4.fc7 updates 682 k

Transaction Summary
================================================== ===========================
Install 0 Package(s)
Update 5 Package(s)
Remove 0 Package(s)

Total download size: 23 M
Is this ok [y/N]: y
Downloading Packages:


Package libwnck-2.18.2-1.fc7.i386.rpm is not signed
[root@JMH-LINUX ~]#

The_Jaymz
1st June 2007, 04:44 AM
For anyone else with this problem, a quick-and-dirty solution is to edit /etc/yum.repos.d/fedora-updates.repo and set gpgcheck=1 to gpgcheck=0
That comes with a risk though.

Demz
1st June 2007, 04:46 AM
why has packages still got the fc Tag? an not f7 ?

SlowJet
1st June 2007, 05:08 AM
The c in fc7 stands for collections, not core.

I think the yum reps are over lapping or mixed.

From fc7rc2 I have libwnck-2.18.0.3.fc7

yet his is way newr.
The only update I got for fc7rc2 was smolt.
I did not alter the repos at all. They were already pointing to the fc7 set.

The package was usighed because it didn't come from fc7 updates.


SJ

danwaineo
1st June 2007, 06:41 AM
I have this same issue. If it didn't come from updates, then where is it from? I see those same packages here:

http://download.fedora.redhat.com/pub/fedora/linux/updates/7/i386/

The_Jaymz
1st June 2007, 06:59 AM
I tweaked the repo file to get it working. Haven't had any problem since then, but I've only been installing software. I don't think any of the packages came from the updates repository.

PeTzZz
1st June 2007, 10:39 AM
I found it reported in the Bugzilla (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=241984). It is fixed now. I don't know how pup (Software Updater) works and notices fixed packages, but you can do yum clean all in the terminal and then yum update.

danwaineo
1st June 2007, 03:38 PM
Thanks Petzzz,

I think they forgot to sign the packages. I downloaded new packages from the redhat download site, since I doesn't look like the mirrors have them yet. Everything works ok now.

-Dan