PDA

View Full Version : Is lame in the default repository?



Sunnz
31st May 2007, 05:12 PM
I tried something like sudo yum install lame but it doesn't work... is it core or extra or do I need to add additional repository?

markkuk
31st May 2007, 05:22 PM
No, lame can't be included in the default repos because of software patents. You need to configure a third-party repo like Livna (http://rpm.livna.org/) or freshrpms (http://freshrpms.net/) (but not both).

Sunnz
1st June 2007, 03:09 AM
So how do I add the repository?

Dies
1st June 2007, 03:44 AM
Click on whatever link you want, my advice is go with Livna, if you choose livna click on the release rpm that matches your version, download and install it. Then try installing lame again.

On the freshrpms site it's the same thing you just click the link it should install automagically.

Don't install both though, and if you do keep one disabled.

Sunnz
1st June 2007, 05:00 AM
Oh, so I just install http://rpm.livna.org/livna-release-6.rpm if I am on FC6?

Thanks.

Sunnz
1st June 2007, 05:09 AM
Hmmm now I've got something like:

http://rpm.livna.org/fedora/6/i386/repodata/repomd.xml: [Errno 12] Timeout: <urlopen error timed out>
Trying other mirror.

I am behind a proxy.

However I have already set up the proxy in /etc/yum.conf and I was able to use core and extra to install stuff.

Does the repository uses a different port or what not?

scuac
1st June 2007, 03:01 PM
Hmmm now I've got something like:

http://rpm.livna.org/fedora/6/i386/repodata/repomd.xml: [Errno 12] Timeout: <urlopen error timed out>
Trying other mirror.

I am behind a proxy.

However I have already set up the proxy in /etc/yum.conf and I was able to use core and extra to install stuff.

Does the repository uses a different port or what not?

I think that the main livna site had a crash yesterday or the day before. I had problem updating some nvidia drivers from there, but today it is working again. Give it another try.

Sunnz
1st July 2007, 04:12 PM
By the way, is MPlayer included in the default repository or do I need third party repos?

Thanks.