PDA

View Full Version : will some one ati video card give me an xorg.conf?



ildg
31st May 2007, 04:02 AM
My video card is ati x1300 64Mb.

I configured xorg.conf properly before, and I backup the file.
This time when I got fc6 reinstalled, I overwrite xorg.conf with mine.
But mplayer doen't work OK, in vo=x11 mode it's slow, and in vo=xv mode is in bad quality.
I did everything I could, and I asked for solutions everywhere, but I didn't get any useful ideas.

I think the last thing I can do is to ask for an xorg.conf file. If you are using ati video card, and your mplayer works fine, please post your xorg.conf file to me.

Thank you!

sideways
31st May 2007, 11:15 AM
If you're using fglrx drivers then you have to use opengl mode in mplayer, xvideo don't work.

Here's my xorg.conf for a machine using fglrx (the monitor section should be replaced to match yours)


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "ddc"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "freetype"
Load "type1"
Load "glx"
Load "dri"
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "L1710B"
DisplaySize 338 270
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 30.0 - 71.0
VertRefresh 56.0 - 75.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "fglrx"
Option "OpenGLOverlay" "off"
Option "VideoOverlay" "on"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "False"
EndSection



If you use the opensource radeon driver ('man radeon' for info) then xvideo should work, and the xorg.conf needs some changes, like this one


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "ddc"
Load "extmod"
Load "fbdevhw"
Load "freetype"
Load "type1"
Load "glx"
Load "dri"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "Generic Monitor"
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 120.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "radeon"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection


Alternatively, try vlc, it seems to always work for me.

ildg
1st June 2007, 01:41 AM
Thank you so very much!

you mean fglrx can't enable xvideo? But I always use fglrx and I clearly remember that I once make vo=xv work. I can't remember which version the kernel was, and which version the fglrx was.

But after I run "yum -y update", mplayer just can't display movies in good quality any more.

vo=xv mode plays movies much smoother than any other modes, so I only want to use vo=xv.

I use mplayer all the time, and I memorized the hot keys of it. I don't want to switch to other players before I try my best to fix it.

I tried vlc last night. I installed it. But, surprised to me, vlc can't play normally, either. When my vlc plays any movies, the display area of vlc wobbles all the time.

It seems that the problem is not mplayer, but my config of video card driver.
Or maybe this version of driver of fglrx has something wrong.

My video card is ati x1300. I installed fglrx through yum, so it must be the newest version.

I attached my xorg.conf. Please someone give me some more hints.


If you're using fglrx drivers then you have to use opengl mode in mplayer, xvideo don't work.

Here's my xorg.conf for a machine using fglrx (the monitor section should be replaced to match yours)


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "ddc"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "freetype"
Load "type1"
Load "glx"
Load "dri"
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "L1710B"
DisplaySize 338 270
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 30.0 - 71.0
VertRefresh 56.0 - 75.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "fglrx"
Option "OpenGLOverlay" "off"
Option "VideoOverlay" "on"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "False"
EndSection



If you use the opensource radeon driver ('man radeon' for info) then xvideo should work, and the xorg.conf needs some changes, like this one


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "ddc"
Load "extmod"
Load "fbdevhw"
Load "freetype"
Load "type1"
Load "glx"
Load "dri"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "Generic Monitor"
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 120.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "radeon"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection


Alternatively, try vlc, it seems to always work for me.

sideways
1st June 2007, 01:55 AM
Your xorg.conf is fine.

Hmm. so mplayer and vlc don't play well? What kernel version do you have ? (uname -r), what version of the fglrx drivers do you have? (rpm -qa | grep fglrx)

This is such a tricky area in linux. Have you tried xine? Did it work ok with an older version of mplayer? I found the latest mplayer to have bugs, maybe do a 'yum remove mplayer' and then get an older version.
You can compile from the source http://www.mplayerhq.hu/design7/dload.html

ildg
1st June 2007, 02:15 AM
Thank you again~

This xorg.conf is the one which I used to make my mplayer wonderfully work. I backed up it on my mobile disk. Every time I reinstall fc6, I can directly use this xorg.conf and need not manually modify it any more.

I'm in the company now, and I will post you the version of kernel & fglrx later.

My mplayer is "SVN-r22817 rpm.livna.org", it's an unstable version. I downloaded mplayer rc1 source and I compiled it myself. When I tried to run it, it still couldn't play smoothly. I will recompile the source step by step again some time and see if the problem happens any more.


Your xorg.conf is fine.

Hmm. so mplayer and vlc don't play well? What kernel version do you have ? (uname -r), what version of the fglrx drivers do you have? (rpm -qa | grep fglrx)

This is such a tricky area in linux. Have you tried xine? Did it work ok with an older version of mplayer? I found the latest mplayer to have bugs, maybe do a 'yum remove mplayer' and then get an older version.
You can compile from the source http://www.mplayerhq.hu/design7/dload.html

ildg
1st June 2007, 12:21 PM
I'm now at home and running fc6.
I post my fglrx version here as you told me:

$ uname -r
2.6.20-1.2952.fc6

$ rpm -qa | grep fglrx
kmod-fglrx-8.36.5-3.2.6.20_1.2952.fc6
kmod-fglrx-8.36.5-3.2.6.20_1.2948.fc6
xorg-x11-drv-fglrx-8.36.5-1.lvn6


Your xorg.conf is fine.

Hmm. so mplayer and vlc don't play well? What kernel version do you have ? (uname -r), what version of the fglrx drivers do you have? (rpm -qa | grep fglrx)

This is such a tricky area in linux. Have you tried xine? Did it work ok with an older version of mplayer? I found the latest mplayer to have bugs, maybe do a 'yum remove mplayer' and then get an older version.
You can compile from the source http://www.mplayerhq.hu/design7/dload.html

sideways
1st June 2007, 12:34 PM
Using the following combination mplayer works well for me, but only with the gl or gl2 video driver (you select it in Preferences->Video)

mplayer-1.0-0.72.20070325svn.lvn6

xorg-x11-drv-fglrx-8.31.5-3.lvn6
kmod-fglrx-8.31.5-1.2.6.18_1.2869.fc6

kernel-2.6.18-1.2869.fc6

ildg
1st June 2007, 12:41 PM
You can't play in xv mode, either?
gl&gl2 also work for me.
but xv style plays in the best quality.
Thank you so much for helping me again and again.
I'll wait for the next version of fglrx and see if the problem can be settled or not.


Using the following combination mplayer works well for me, but only with the gl or gl2 video driver (you select it in Preferences->Video)

mplayer-1.0-0.72.20070325svn.lvn6

xorg-x11-drv-fglrx-8.31.5-3.lvn6
kmod-fglrx-8.31.5-1.2.6.18_1.2869.fc6

kernel-2.6.18-1.2869.fc6