PDA

View Full Version : Yumex



juanpedro
30th May 2007, 05:04 AM
I get the following error when I try to start yumex

Component: yumex
Version: 1.2.3
Summary: TB3638d33a ConfigParser.py:511:get:NoSectionError: No section: 'main'

Traceback (most recent call last):
File "/usr/share/yumex/yumexmain.py", line 1115, in ?
mainApp = YumexMainApplication()
File "/usr/share/yumex/yumexmain.py", line 507, in __init__
self.profile = Profile()
File "/usr/lib/python2.4/site-packages/yumex/yumexUtils.py", line 1202, in __init__
self.active=self.profiles.get( "main", "LastProfile" )
File "/usr/lib/python2.4/ConfigParser.py", line 511, in get
raise NoSectionError(section)
NoSectionError: No section: 'main'

Local variables in innermost frame:
d: {}
vars: None
self: <ConfigParser.ConfigParser instance at 0x93d4e8c>
raw: False
section: main
option: LastProfile


the odd thing is is it just start today and I recently installed LDAP via webmin but other than that nothing else. Yumex was working earlier but I get the aboce error when I try to run yumex now. Any help will be appreciated

sideways
30th May 2007, 10:19 AM
Check your /etc/yum.conf, it looks like there is a missing [main] section, it should look something like this:


[main]
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=redhat-release
tolerant=1
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
metadata_expire=1800

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d


If it looks ok, then try yum update from the command line, see if it gives the same error

mit
30th May 2007, 02:24 PM
Look like a problem with /etc/yumex.profiles.conf




cat /etc/yumex.profiles.conf
[main]
lastprofile = yum-enabled

juanpedro
30th May 2007, 10:56 PM
Look like a problem with /etc/yumex.profiles.conf




cat /etc/yumex.profiles.conf
[main]
lastprofile = yum-enabled

This solved the problem. My file was blank.
Thanks