PDA

View Full Version : Permissions



dunff2k
30th May 2007, 12:11 AM
Hey guys

I have a FAT32 partition mounted at


/media/vfat1


I can read files from this, however only root can write to it due to permissions. The root group can access files.

I tried adding myself to the root group and assigning this writing priviledges to no avail,

Any ideas?

Paul

danwaineo
30th May 2007, 12:25 AM
I'm pretty sure you need to change the permissions of /media/vfat1 so that you have write permissions.

When I do stuff like this I usually make myself the owner and users the group. Then I add myself and any other users I want to access /media/vfat1 to the "user" group. This can be done using:

System --> Administration --> Users and Groups

Then I would give the "user" group right acess to /media/vfat1 by:

chmod g+w /media/vfat1

There are lots of other ways of doing this, but I would caution against adding yourself or anyone else to the "root" group. You can screw things up that way.

Hope this helps.

dunff2k
30th May 2007, 10:19 AM
thanks for your response

This still doesn't work though.

I don't receive any errors from changing the permissions as you suggested, but the change is never reflected. changing the group has the same effect. the owner is always root with read and write access, group is root with read access

I am working as root. Also trying to change the owner gives me the message that "operation is not permitted"

Would it make a difference that vfat1 is a folder and not a file?

Paul

markkuk
30th May 2007, 10:42 AM
You can't change file/directory ownership or permissions on VFAT partitions by normal means. If the partition is mounted at boot by using /etc/fstab, you must set the mount options in that file.

sideways
30th May 2007, 10:43 AM
Create a directory /mnt/vfat1, put this line in /etc/fstab (replace /dev/hda1 with your vfat partition)

/dev/hda1 /mnt/vfat1 vfat defaults,rw,umask=0000 0 0
and type 'mount -a'. Now access the drive via /mnt/vfat1

dunff2k
30th May 2007, 09:49 PM
thanks that works great

What do the parameters after and including the "defaults" part actually mean?

I can see what the earlier bits mean

Paul

sideways
30th May 2007, 10:06 PM
http://www.tuxfiles.org/linuxhelp/fstab.html

the umask=0000 is the important bit here, it allows all users full access.

fat32 has no concept of ownership, so no point trying to specify ownership on specific files/directories.

The "0 0' bit at the end means the dump utility will ignore the partition, and fsck won't try to check it on boot (which is what you want)