View Full Version : Running 32bit Firefox in F7 x86_64

30th May 2007, 12:01 AM
I was just wanting to try FF 32bit in F7 RC2 x86_64 there seems to be a lot of issues with common plugins (ie java, flash etc) that I think I'd just rater stick with the 32 bit version. Can 64 bit browser really be that much better ? I tried running it and got "libstdc++.so.5 no such file dir etc" So I found this rpm for it and I was thinking of installing it but had second doubts. Really new to 64 bit env. Will it 1) fix the issue at hand? 2) not take place some 64 bit version that will make my whole system keel over.

BTW I did *play* with a beta version of XP 64bit and MS I think had the same set of issues and had both sets of browser available.

30th May 2007, 12:03 AM
BTW googling got me this http://rpmfind.net/linux/rpm2html/search.php?query=libstdc%2B%2B.so.5

30th May 2007, 08:59 AM
thought this would be an easy question .

30th May 2007, 10:06 AM
Use "yum install firefox-32" to install the 32-bit Firefox browser in F7 or FC6 x86_64.

30th May 2007, 02:16 PM
Use "yum install firefox-32" to install the 32-bit Firefox browser in F7 or FC6 x86_64.
Sorry yum has not been good to me on this spin All I get is it can't open/read repomd.xml
I *tried* to configure yum's files per several articles via google and no luck.

Semi related - anyone have a url that explains shared libraries "*.so" on linux ? basically how an when an apploads where it search and looked for etc. I have some other 32 bit software that I need running but it too can't find gcc 32 bit libs. Also tried install vmware but configuration which tried to compile complained and the one thing I could find is it needs 32 bit compatibility libraries install.

30th May 2007, 03:11 PM
It's possible that F7RC2's yum config files point to F7 repos that don't exist yet. Try again tomorrow after F7 repos are opened.
Linux libraries are explained at: http://tldp.org/HOWTO/Program-Library-HOWTO/index.html

30th May 2007, 04:46 PM
Thanks for being very helpful. I like what I see with F7 in RC2 and think now I'm going to wait and reinstall with GA version before I get it too configured. I also have some work in moving data/partitons on the disk around to make it the way I want it. The only disappointment I've had is my optron 250s don't support kvm AFAICT :-( Some issues with getting vmware configured.
Think in the final setup I'm going to fix it to boot between 64 and 32 bit editions.
I assume the set up there is to have /home in it's own partition and the remaining on separate. (i.e share "/home" between the two) I assume that can be done. Guess ids no. need to be the same one both.
I was thinking of getting vista on there too but just looked at the prices ... ouch! Not going to happen.

30th May 2007, 05:49 PM
Try enabling the development repos in /etc/yum.repos.d/ and disable the ones in fedora.repo and fedora-updates.repo, until they are fixed tomorrow. Then just do the opposite of it to get everything working properly, tomorrow.