PDA

View Full Version : changing user ID number: sharing settings and preferences between distributions



slade17
29th May 2007, 08:15 PM
fedora starts user ID numbers at 500. debian starts them at 1000. I want to be able to share settings like firefox bookmarks and gaim profiles, so i want to change both operating systems to have the same user and group ID.

now, I already did this before, which is what is annoying me. I had everything working perfectly, then reinstalled debian, and I can't remember what I did before. right now, the commands i'm trying are:


groupmod -g 500 colin
usermod -u 500 -g 500 -G 500 colin

if i use the command "id colin", everything displays properly. if i look at my home folder, it appears to have the proper permissions. but when I start gnome, i run into numerous errors regarding settings/preferences. I've tried changing this on both fedora and debian, with the same result. changing the user and group IDs through the GUI has also failed.

I think from now on, I should document all my steps when I do something like this...

brunson
29th May 2007, 09:09 PM
You can change the GID of the user, but that doesn't change the ownership of the files. Try: "chown -R colin.colin ~colin".

slade17
29th May 2007, 09:52 PM
You can change the GID of the user, but that doesn't change the ownership of the files. Try: "chown -R colin.colin ~colin".
the man page for usermod says that changing the user ID number should change file permissions on the home folder and its contents, and it appears that that happened. i tried "chown -R 500 /home/colin", along with chown and chrgrp, with no effect.

brunson
29th May 2007, 10:00 PM
Interesting. I've never used usermod, so there you go. If it were me, I'd just delete the account and recreate it specifying the GID and UID.

Sorry for the misinfo.

slade17
29th May 2007, 10:04 PM
Interesting. I've never used usermod, so there you go. If it were me, I'd just delete the account and recreate it specifying the GID and UID.

Sorry for the misinfo.
i tried that. it created the account, but without a home folder.

slade17
30th May 2007, 09:39 PM
hmm, so, i got it working, and i really don't know how. it would appear that executing chmod -R 755 /home/colin resulted in some files not having writing and executing permissions by the owner... i found this out through nautilus, then had to go back and use chmod with the a=x style argument.

wdgiles
30th May 2007, 11:09 PM
I've always used Webmin for user management, I'm a GUI lover, so there. It allows you to manually specify the UID. I've run into the same thing with a shared MacOS and Fedora setup.

dscott23
31st May 2007, 01:40 AM
I came across the same issue when I changed my server over to Debian, desktop is FC6. I use NFS, and instead of changing my UID/GID on fedora, I exported my shares on the server with the "all_squash,anonuid=1000,anongid=1000" options. I don't know if this would work with gaim profiles, maybe gaim wouldn't read them properly on the fedora system, but it works fine for regular file access between the two systems.. keeps the permissions from getting all screwed up.