PDA

View Full Version : FFMPEG problem



SideshowMel
28th May 2007, 05:53 PM
I'm trying to convert an AVI file to a WMV file (so I can stream it to my xBox360 using a VMWare WindowsXP Virtual Machine running under FC6... (the Windows Movie Maker under the virtual machine won't work because it doesn't detect proper A/V devices (not a big surprise for a virtual machine))), and I get an error when trying to use ffmpeg. I got errors trying to update ffmpeg, too, but I ignored them. Anyways, I've had some issues with VLC, and I installed a FreshRPMs VLC installer overtop of a Livna installer, and it caused more problems than I can count. To fix that, I just removed them all, and installed the FreshRPMs installer and VLC worked fine. Then when I installed the RealPlayer, I got SELinux errors, but RealPlayer and VLC seem to be working ok (although whenever my box starts up it gives several SELinux errors, all related to either RealPlayer or VLC codecs, that popup and disappear quickly.) I know that sounds like a lot, but I think all these problems are related, since they all have to do with A/V stuff.

So here is the error I get trying to use FFMPEG:
[root@localhost ~]# ffmpeg
ffmpeg: symbol lookup error: /usr/lib/libavcodec.so.51: undefined symbol: faacDecOpen

Here is when trying to update FFMPEG:

(UPDATE DETAILS: "ffmpeg-libs - 0.4.9-0.37.20070503.lvn6.i386 updates ffmpeg-libs - 0.4.9-0.35.20070204.lvn6.i386")... then it gives the error:
Missing Dependency: faad2 < 2.5 is needed by package ffmpeg-libs

I really have no clue what to do or what these errors even mean. Any help would be appreciated.

Thanks.

PS:
[root@localhost ~]# uname -r
2.6.20-1.2948.fc6

SideshowMel
28th May 2007, 06:02 PM
Here are some of the codec errors I mentioned. It appears that I can now use the Livna Repo version of VLC just fine, although I still get the errors below:

[root@localhost ~]# yum remove videolan-client
Loading "installonlyn" plugin
Setting up Remove Process
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package vlc.i386 0:0.8.6b-5.lvn6.2 set to be erased
--> Running transaction check

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Removing:
vlc i386 0.8.6b-5.lvn6.2 installed 20 M

Transaction Summary
================================================== ===========================
Install 0 Package(s)
Update 0 Package(s)
Remove 1 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
/etc/selinux/targeted/contexts/files/file_contexts: Multiple same specifications for /usr/lib/vlc/codec/libdmo_plugin.so.
/etc/selinux/targeted/contexts/files/file_contexts: Multiple same specifications for /usr/lib/vlc/codec/librealaudio_plugin.so.
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
/etc/selinux/targeted/contexts/files/file_contexts: Multiple same specifications for /usr/lib/vlc/codec/libdmo_plugin.so.
/etc/selinux/targeted/contexts/files/file_contexts: Multiple same specifications for /usr/lib/vlc/codec/librealaudio_plugin.so.
Removing : vlc ######################### [1/1]

Removed: vlc.i386 0:0.8.6b-5.lvn6.2
Complete!
[root@localhost ~]# yum install videolan-client
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for vlc to pack into transaction set.
vlc-0.8.6b-5.lvn6.2.i386. 100% |=========================| 87 kB 00:00
---> Package vlc.i386 0:0.8.6b-5.lvn6.2 set to be updated
--> Running transaction check

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Installing:
vlc i386 0.8.6b-5.lvn6.2 livna 7.9 M

Transaction Summary
================================================== ===========================
Install 1 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 7.9 M
Is this ok [y/N]: y
Downloading Packages:
(1/1): vlc-0.8.6b-5.lvn6. 100% |=========================| 7.9 MB 00:10
Running Transaction Test
/etc/selinux/targeted/contexts/files/file_contexts: Multiple same specifications for /usr/lib/vlc/codec/libdmo_plugin.so.
/etc/selinux/targeted/contexts/files/file_contexts: Multiple same specifications for /usr/lib/vlc/codec/librealaudio_plugin.so.
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
/etc/selinux/targeted/contexts/files/file_contexts: Multiple same specifications for /usr/lib/vlc/codec/libdmo_plugin.so.
/etc/selinux/targeted/contexts/files/file_contexts: Multiple same specifications for /usr/lib/vlc/codec/librealaudio_plugin.so.
Installing: vlc ######################### [1/1]

Installed: vlc.i386 0:0.8.6b-5.lvn6.2
Complete!

ryptyde
28th May 2007, 06:32 PM
Those errors have been showing up quite frequently and I see the warnings during boot but my vlc installation seems to be working fine.

There has been other posts on this and an explanation as to why, I think it was something about SELinux (http://forum.fedoraforum.org/showthread.php?t=154227).

ajamison
29th May 2007, 05:35 AM
I have the first error also but i do not use the vlc thing so i do not have that

SideshowMel
15th June 2007, 03:28 PM
ok, I'll look into those suggestions. Thanks!