PDA

View Full Version : Missing Dependency



chrfel
28th May 2007, 04:48 PM
I am trying to update with yum, but I keep getting an error: Missing Dependency: faad2 < 2.5 is needed by package ffmpeg-libs. I can't even donwload the rpm and try to install it without getting this warning. Any help would by much appreciated. Thank you!

Chris :confused:

JN4OldSchool
28th May 2007, 05:00 PM
What I usually do in cases like this is just use yumex and exclude ffmpeg-libs from the update. Then, when the update is done try to update again. This will usually work the kink loose. You might just have to wait a day or so before you can update this package.

chrfel
28th May 2007, 09:34 PM
Thank you. I will give it a shot. Do you think that this issue will be fixed with Fedora 7? I woul d rather have the update instead of going around it. However, I will do what I have to do to get over it. Thank you for your help; Go Gators!

kalaka
1st June 2007, 02:28 AM
The issue has nothing to do with the system itself. The repo from which you updated faad2 is different from the repo which you used to update ffmpeg. I'd wait a couple of days for the repos to be updated, then you should be able to update ffmpeg.

kosh
1st June 2007, 03:36 PM
This can happen if you use LIVNA and FRESHRPMS at the same time. Try to reinstall the packages using just one repo.