PDA

View Full Version : sound for multiple programs at once ALSA/OSS



breintje
27th May 2007, 10:23 PM
I am quite a beginner with linux, started using it because my previous pc was a ME disaster, and W2K was even worse, so I started with FC4. I liked it so my new pc is also linux.
I do run fc-6 64 bit version and am having some problems with sound on multiple programs. Since I play Wolfenstein ET and want to run teamspeak next to it it does give problems. The point is that when I run teamspeak I cannot get sound on another program. When teamspeak is running and I go to preferences-sound and press test it says me "cannot find the object or it is already in use". I do not have a soundcard, sound is onboard. My motherboard is an ASUS M2N-E. Soundcard detection says "nVidia MPC 55 high definition audio".
My friends have tried to help, but it is not working yet, so they directed me here.
Also my microphone did not work, It has worked once, when a friend gave me a script for it (with symbolic link to auto start on init 5), but after reboot the soundcard seems to mix it up again. When someone talks to me on TS it does echo it, like if you would connect the headphones outline to the headphones, but also to the mike input.
This is about all what is wrong, does anyone know a possible solution? My main concern is the sound now the mike can wait, but maybe those symptomes can help find a solution?

Thanks in advance,
Breintje

Dies
28th May 2007, 12:50 AM
http://wiki.archlinux.org/index.php/Allow_multiple_programs_to_play_sound_at_once

http://gentoo-wiki.com/HOWTO_ALSA_sound_mixer_aka_dmix

breintje
28th May 2007, 09:01 AM
I have gone to that second website, and created a .asoundrc file what they say there, but still it is the same. Also some of the commands that they use do not work.
I can get the sound of 2 Mplayers at once , but if teamspeak runs no other program can use sound
There's to much info on those sites and i cannot find what I have to do.