View Full Version : Impressed with Fedora but have some dumb questions

26th May 2007, 06:51 AM
Hey, I'm a long time computer guy going back to mainframes, but never tried Linux. I have 7 computers at home and at grown kids houses, maintaining Windows on them all. I was putting together my latest box (Intel DH965WH MB, Intel E6600 Core 2 Duo, 4GB PC6400 memory, Raptor 10K RPM hard drive, SATA 300GB hard drive). I was just not looking forward to yet another Windows install. So I figured, time to give Linux a shot.

Pulled down Fedora 7 Test 4 via BitTorrent, burned to a DVD, booted.

All I've got to say is wow. This is a way cleaner and nicer install/setup than Windows + Office. It recognized all my hardware and did all the drivers. (I tried loading drivers from the Intel site but it said mine were already up-to-date!) It loaded all the software I cared about automatically. I think I'm in love. I've figured out most of what I need to know so far, enough to get lots of work done and also install and run IBM WebSphere on the box (for testing/education purposes). I got it to connect to my Windows boxes to share files. I installed the IBM Lotus Mobile Connect client so I could VPN into work. I figured out how to handle all the archive packages to help install all this software. I figured out how to mount my 300 GB NTFS drive and use it from Linux.

I'm learning the command language. I also like the GNOME UI, pretty clean and simple.

So here's my dumb questions of the moment:

1) Just for fun I want to use the mail command to send mail. How do I configure it to connect to my ISP's SMTP server (which requires userid/password authentication)? Is the trick to edit the sendmail.mc file? I looked in there and didn't really see where to put the userid and pw.

2) It says I have 99 packages to update. But the update installer just sits there forever saying "loading package information" or some such. Should I just wait until the May 31st release date and reinstall? I have plenty of ISP bandwidth.

3) I have a Memorex 16x DVD writer drive. When I try to burn a CD with data files it says "error could not write try a slower speed" or some such. What do I need to do here?

26th May 2007, 07:12 AM
are you running from the DVD or did you install to your harddrive?

26th May 2007, 08:17 AM
Firstly, remember you're running a Test release, so Expect Bugs! And when you find them, please report them on the Fedora bugzilla.

Sendmail is famously hard to configure. My suggestion would be to install postfix (a more modern mail transport agent) instead. You can install postfix from the package installer or type "yum install postfix" on the command line. Information on setting up SMTP authentication on outbound mail with postfix, see http://www.thecabal.org/~devin/postfix/smtp-auth.txt . See section 5, in particular.

The problems with the package updater are possibly a bug, however updating packages may be slow anyway (there's fewer mirrors to choose from for a test release).

Not sure what to suggest for your CD-writer problems. Did you try a slower speed? You may need to check the system logs to get more error information.

26th May 2007, 01:07 PM
1) Try and install postfix, it's easier to setup and use in my opinion
2) Try running yum or install smart (which can be run with a gui frontend with the --gui option)
3) I had some problems myself when I tried to burn a couple of backup DVD's. I can't remember what the error message was but it was resolved by setting the open allowable files to unlimited (some kernel issue). As I seem to have bookmarked the link, check it out here http://fy.chalmers.se/~appro/linux/DVD+RW/tools/

26th May 2007, 01:29 PM
I would certainly wait for Fedora 7 + 1 week (for critical patches). Then reinstall. Until then, learn as much as you can. Focus on getting familiar with the 'yum' command... It's like Windows Update on steroids. The yum command is critical when installing new software, drivers and codecs - you'll notice Fedora does not include any proprietary software (some video drivers, some codecs, etc) when first installed. But all these can be added post-install using yum.

Also make sure you have your Linux installation separated into at least two partitions: one for " / " and one for " /home " . This will make future upgrades and reinstalls much easier, and isolate your 'user' data from your operating system data.


26th May 2007, 03:29 PM
are you running from the DVD or did you install to your harddrive?

I installed to the hard drive. I had Windows 2000 on there, but did a clean install (erased/reformatted the hard drive).

Actually that spawns YADQ (Yet Another Dumb Question). How can I tell what file system my boot partition is using? I see the device is /dev/sda1 but its properties don't tell me anything.

26th May 2007, 03:56 PM
for your yum problem you could also open up a terminal and type yum update, that will just make a list of all the packages on your computer to update but won't look for the information, after showing you the list all you have to do is either accept it or not and it will install them all ;)

good luck and welcome to the club!!

26th May 2007, 03:59 PM
Actually that spawns YADQ (Yet Another Dumb Question). How can I tell what file system my boot partition is using? I see the device is /dev/sda1 but its properties don't tell me anything.

Switch to root user using 'su -' and type 'fdisk -l', it will list your drives and partitions on them and the filesytem (if any)

What are you using to burn dvds, in k3b you can certainly set a lower speed, from the command-line tool cdrecord you can type something like
mkisofs -R <directory with data files> | cdrecord -v -speed=4 dev=/dev/dvd -data -eject -

Sendmail configuration is a little tricky, even if you set it up correctly you must be sure your isp will accept mail from your server. Postfix seems the preferred solution, there are quite a few guides eg http://rimuhosting.com/support/settingupemail.jsp

yum is notoriously slow, with 99 packages available for update it may well take a long time. Try disabling the auto-updater
su -
service yum-updatesd stop
chkconfig --del yum-updatesd

and run the update manually from the command line (to see more output)
yum update

none of your questions are dumb.

26th May 2007, 04:23 PM
just checking. the way the initial post was worded, it sounded like you were doing a live cd setup.