PDA

View Full Version : How To Re-install YUM Fedora Core 6



aussiecanuck46
22nd May 2007, 03:03 PM
I'm not quite a newbie but I sure feel like one now. I've recently had connection problems with yum. I thought it had something to do with a recent change I'd made to crash-hat repository, but I now believe that was wrong. I figured the best way to remove the crash-hat part would be to remove and re-install yum. The uninstall part was easy enough but I find myself unable to re-install yum. Paraphrasing Oliver Hardy to Stan Laurel "There's another fine mess I've gottten myself into."

I've studied the yum wiki and downloaded the most recent version (3.2.0) from http://linux.duke.edu/projects/yum/. However there doesn't seem to be a rpm version there. Fine I'll use the tarball. The INSTALL file within the tarball says to use "make make install (if you're a masochist)". There is no ./configure within that tarball as I would expect there to be. After applying make and make install when I execute yum I receive a message "no module named yum". further research led me to understand that I should execute python and apply "import yum" at the >>> prompt. When I do that I get "no module named rpm". importing rpm then results in the same error message again.

Instead of being a masochist the yum wiki suggests I install an rpm package instead. I might be able to build one if I had rpmbuild installed. but I don't have rpmbuild, and I don't have yum to install it with. I've been unable to find an appropriate yum rpm (for FC6 x86_64).

Can anyone suggest how I might either get the appropriate rpm or otherwise fix my yum problem?

shess01
22nd May 2007, 03:11 PM
Check your install FC6 DVD/CD's. I have the DVD and the yum rpm's are in the /Fedora/RPMS directory.

aussiecanuck46
22nd May 2007, 07:30 PM
As suggested I found /media/FC-6 x86_64 Disc 1/Fedora/RPMSyum-3.0.6.noarch.rpm and a couple other rpm's on CD #1. Simply installing those rpm's with the "-i" switch allowed me to use yum again. However, yum continued to fail indicating a problem with crash-hat "http://crash.fce.vutbr.cz/crash-hat/6/repodata/repomd.xml: [Errno 14] HTTP Error"

By editing file /etc/yum.repos.d/crash-hat.repo and setting "enabled=0" I was able to get past this error.

Now all I have to do is figure out how to get System Update back onto my Application menu and I'll be all set.

aussiecanuck46
22nd May 2007, 09:10 PM
I've solved that bit of bother now too by installing pirut (yum install pirut). I recall now uninstalling that rpm when I uninstalled yum in the first place as yum is dependent on it.