PDA

View Full Version : ffmpeg stoped working



Alex135
20th May 2007, 08:14 PM
ffmpeg was working just yesterday, but now i go and i try and just even type in ffmpeg and it doesn't work. I did only an update inbetween.

[Alex@localhost ~]$ ffmpeg
ffmpeg: symbol lookup error: /usr/lib/libavcodec.so.51: undefined symbol: faacDecOpen
[Alex@localhost ~]$

I have looked at the advice listed here: http://forums.fedoraforum.org/showthread.php?t=143067
and i have done what was wanted, so i removed faad2 and faac
When i did it, it got rid of them along with mplayer, ffmpeg-libs, ffmpeg, libquicktime, mjpegtools-libs, mplayer-skins, mjpegtools, mplayerplug-in, transcode, and swfdec

i reinstalled them with freshrpms disabled


[root@localhost ~]# yum install faac faad2 ffmpeg ffmpeg-libs libquicktime mjpegtools mplayer mplayer-skins mplayerplug-in swfdec transcode --disablerepo=freshrpms
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
dries 100% |=========================| 951 B 00:00
poptop-stable 100% |=========================| 951 B 00:00
livna 100% |=========================| 1.1 kB 00:00
core 100% |=========================| 1.1 kB 00:00
core-source 100% |=========================| 951 B 00:00
updates 100% |=========================| 1.2 kB 00:00
pptp-stable 100% |=========================| 951 B 00:00
macromedia 100% |=========================| 951 B 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Excluding Packages from Extra Fedora rpms dries - 6 - i386
Finished
Excluding Packages from Livna for Fedora Core 6 - i386 - Base
Finished
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package mplayer-skins.noarch 0:1.8-1.fc6.rf set to be updated
---> Package ffmpeg.i386 0:0.4.9-0.35.20070204.lvn6 set to be updated
---> Package ffmpeg-libs.i386 0:0.4.9-0.35.20070204.lvn6 set to be updated
---> Package mplayer.i386 0:1.0-0.33.rc1.fc6.rf set to be updated
---> Package faad2.i386 0:2.5-1.fc6.rf set to be updated
---> Package mjpegtools.i386 0:1.9.0-0.2.fc6.rf set to be updated
---> Package mplayerplug-in.i386 0:3.35-1.fc6.rf set to be updated
---> Package transcode.i386 0:1.0.2-12.lvn6 set to be updated
---> Package swfdec.i386 0:0.4.3-2.lvn6.1 set to be updated
---> Package faac.i386 0:1.25-2.lvn6 set to be updated
---> Package libquicktime.i386 0:0.9.10-3.lvn6 set to be updated
--> Running transaction check
--> Processing Dependency: libmjpegutils-1.8.so.0 for package: transcode
--> Processing Dependency: libSDL_gfx.so.0 for package: mjpegtools
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package SDL_gfx.i386 0:2.0.15-1.fc6.rf set to be updated
---> Package mjpegtools-libs.i386 0:1.8.0-7.lvn6 set to be updated
--> Running transaction check

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Installing:
faac i386 1.25-2.lvn6 livna 82 k
faad2 i386 2.5-1.fc6.rf dries 191 k
ffmpeg i386 0.4.9-0.35.20070204.lvn6 livna 169 k
ffmpeg-libs i386 0.4.9-0.35.20070204.lvn6 livna 1.6 M
libquicktime i386 0.9.10-3.lvn6 livna 343 k
mjpegtools i386 1.9.0-0.2.fc6.rf dries 859 k
mplayer i386 1.0-0.33.rc1.fc6.rf dries 4.6 M
mplayer-skins noarch 1.8-1.fc6.rf dries 13 M
mplayerplug-in i386 3.35-1.fc6.rf dries 504 k
swfdec i386 0.4.3-2.lvn6.1 livna 438 k
transcode i386 1.0.2-12.lvn6 livna 2.5 M
Installing for dependencies:
SDL_gfx i386 2.0.15-1.fc6.rf dries 53 k
mjpegtools-libs i386 1.8.0-7.lvn6 livna 229 k

Transaction Summary
================================================== ===========================
Install 13 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 24 M
Is this ok [y/N]: y
Downloading Packages:
(1/12): mplayer-skins-1.8 100% |=========================| 13 MB 01:33
(2/12): ffmpeg-0.4.9-0.35 100% |=========================| 169 kB 00:01
(3/12): ffmpeg-libs-0.4.9 100% |=========================| 1.6 MB 00:09
(4/12): mplayer-1.0-0.33. 100% |=========================| 4.6 MB 00:31
(5/12): SDL_gfx-2.0.15-1. 100% |=========================| 53 kB 00:00
(6/12): mjpegtools-1.9.0- 100% |=========================| 859 kB 00:05
(7/12): mplayerplug-in-3. 100% |=========================| 504 kB 00:02
(8/12): transcode-1.0.2-1 100% |=========================| 2.5 MB 00:15
(9/12): swfdec-0.4.3-2.lv 100% |=========================| 438 kB 00:02
(10/12): faac-1.25-2.lvn6 100% |=========================| 82 kB 00:00
(11/12): libquicktime-0.9 100% |=========================| 343 kB 00:01
(12/12): mjpegtools-libs- 100% |=========================| 229 kB 00:01
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing: faac ####################### [ 1/13]
Installing: mplayer ####################### [ 2/13]
Installing: faad2 ####################### [ 3/13]
Installing: ffmpeg-libs ####################### [ 4/13]
Installing: ffmpeg ####################### [ 5/13]
Installing: libquicktime ####################### [ 6/13]
Installing: mjpegtools-libs ####################### [ 7/13]
Installing: SDL_gfx ####################### [ 8/13]
Installing: mplayer-skins ####################### [ 9/13]
Installing: mjpegtools ####################### [10/13]
Installing: mplayerplug-in ####################### [11/13]
Installing: transcode ####################### [12/13]
Installing: swfdec ####################### [13/13]

Installed: faac.i386 0:1.25-2.lvn6 faad2.i386 0:2.5-1.fc6.rf ffmpeg.i386 0:0.4.9-0.35.20070204.lvn6 ffmpeg-libs.i386 0:0.4.9-0.35.20070204.lvn6 libquicktime.i386 0:0.9.10-3.lvn6 mjpegtools.i386 0:1.9.0-0.2.fc6.rf mplayer.i386 0:1.0-0.33.rc1.fc6.rf mplayer-skins.noarch 0:1.8-1.fc6.rf mplayerplug-in.i386 0:3.35-1.fc6.rf swfdec.i386 0:0.4.3-2.lvn6.1 transcode.i386 0:1.0.2-12.lvn6
Dependency Installed: SDL_gfx.i386 0:2.0.15-1.fc6.rf mjpegtools-libs.i386 0:1.8.0-7.lvn6
Complete!
then i tried to run ffmpeg again and it still has the same problem.

I did everything i was told and it isn't working, what's wrong?

jdeslip
20th May 2007, 08:26 PM
Notice that you did NOT get them from freshrpms - you got them from livna (with a mix of dries). Try removing them again then temporarily excluding the livna and dries repository while you install them.

Alex135
20th May 2007, 08:43 PM
[root@localhost ~]# yum install faac faa2 --disablerepo=freshrpms --disablerepo=livna
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Could not retrieve mirrorlist http://mirrors.fedoraproject.org/mirrorlist?repo=core-6&arch=i386 error was
[Errno 4] IOError: <urlopen error (111, 'Connection refused')>
Error: Cannot find a valid baseurl for repo: core
[root@alexander ~]# yum install faac faad2 --disablerepo=freshrpms --disablerepo=livna
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages from Extra Fedora rpms dries - 6 - i386
Finished
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package faad2.i386 0:2.5-1.fc6.rf set to be updated
---> Package faac.i386 0:1.25-2.fc6.rf set to be updated
--> Running transaction check

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Installing:
faac i386 1.25-2.fc6.rf dries 82 k
faad2 i386 2.5-1.fc6.rf dries 191 k

Transaction Summary
================================================== ===========================
Install 2 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 274 k
Is this ok [y/N]: y
Downloading Packages:
(1/2): faad2-2.5-1.fc6.rf 100% |=========================| 191 kB 00:04
(2/2): faac-1.25-2.fc6.rf 100% |=========================| 82 kB 00:01
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing: faac ######################### [1/2]
Installing: faad2 ######################### [2/2]

Installed: faac.i386 0:1.25-2.fc6.rf faad2.i386 0:2.5-1.fc6.rf
Complete!

i did that and then i put back in all the other stuff that was uninstalled and it still is doing the same thing


[edit] NVM prob fixed, thanks for helping me get the problem fixed over msn, jdeslip, it was the same prob i just didn't get it configured right for all the apps.

lazlow
20th May 2007, 09:50 PM
Alex

I guess I did not make my point last time about repo hell. You can mix core and extras with any ONE other repo. ONLY ONE. You can use livna, freshrpms, dries or whatever. But you can only use ONE. When you fully understand (a year or more down the road) what you are doing, you can pick and choose packages from all the repos. Until you know absolutely what you are doing, just do not do it.

Disable all repos (excluding core and extras) except for ONE.