PDA

View Full Version : cfdisk command is missing



rexus
20th May 2007, 09:51 AM
Hi guys,

recently, I've been erasing my rpm packages in my FC6 system.
well, the problem is that, prior to erasing my rpm packages, I can still do a cfdisk command in my system but now I can't do anymore.

Do you have any solution to this? do I have to install some rpms in order for cfdisk to be available again?

regards,
Adhika

doss
20th May 2007, 10:25 AM
unless you installed it from somewhere i dont think so

http://forums.fedoraforum.org/showthread.php?t=152715

sorry i couldnt help

rexus
20th May 2007, 03:00 PM
thanks doss, don't say you couldn't help.. infact, you help a lot.
I followed your link and read it.

I have parted installed already with the FC6, and I've read the fdisk documentation as well.
I just knew that fdisk was not designed for large partition.

The problem why I need cfdisk is actually because it is easy to use and it shows how much empty partition I haven't allocated yet. With parted I can see this empty partition as well because it supports my 80Gig hard drive.


# parted /dev/sda <<< I'm using SATA though. I don't know why it shows sda instead of hda :P

(parted) print free

Number Start End Size Type File system Flags
1 32.3kB 107MB 107MB primary ext3 boot
2 107MB 6556MB 6449MB primary ext3
3 6556MB 9780MB 3224MB primary ext3
4 9780MB 28.1GB 18.3GB extended lba
5 9780MB 13.0GB 3224MB logical ext3
6 13.0GB 15.2GB 2155MB logical ext3
7 15.2GB 19.5GB 4302MB logical ext3
8 19.5GB 21.6GB 2155MB logical linux-swap
9 21.6GB 23.8GB 2155MB logical linux-swap
10 23.8GB 24.3GB 526MB logical ext3
11 24.3GB 28.1GB 3775MB logical ext3
28.1GB 80.0GB 52.0GB Free Space

and there you go, I can see my free partition

rexus
20th May 2007, 05:50 PM
http://fedoraforum.org/forum/attachment.php?attachmentid=12183&stc=1

as you can see in the above link, I currently have 48.38GB and 3.52GB unallocated space
I want to use that space now, but the problem now is, I can use only the 3.52GB one.

I've tried to extend the extended partition and I even tried to extend the last partition but it just wont do. Do you have any solution to this?

how can I delete the lastest partition which is unallocated as well so that the unallocated space is increasing instead of having 2 unallocated space?

thank you,
rexus

rexus
20th May 2007, 06:42 PM
Oh man, I'm very sorry, after I restart the laptop and entered my FC6 DVD installation, and proceed up to the step where we have to configure the partition manually, I just play a bit with it and don't save anything an after that I restart the laptop and done, I can have the latest partition as well.

but if any of you ever experience this before, please let me know how to get that unallocated space to become part of the extended space.

thank you,
rexus