View Full Version : very weird BIOS? thing?

18th May 2007, 11:07 AM
Wow this one has me flummoxed.
1) this is a Pentium D box, two years old that has had almost no problems, this appeared after I installed a new monitor (not wide screen) which needed no new drivers or anything to work. Along with the monitor (19" Samsung) I installed anew Samsung keyboard (PLEOMAX)

2) OK the symptoms: on boot where one would normally tap a key to enter the full boot menu (this is a dual boot system on an 80 G hard disk which has windoze on most of it--20 G for FC6) the keyboard does not register anything at all, as if it were not connected. not too bad since I seldom go into XP except to let my son play Magic School Bus.

3) I thought maybe I'd check the install CD and see if I could run a repair off of that. But it won't start up off the CD. Hmmmmm, so I went to check the BIOS to see if that got changed for some reason. Can't find it! F8 takes me to a RAID implementation screen, but I neither use RAID or want to. F2 does nothing, although that is what I remember as the func key for the BIOS.

4) Then, on startup I get a very funny message that my home folder is not allowed to open because it is not premitted for me to access it. But then it does open of course. So what the heck is up?

5) The only other piece of information is that I recently added a third computer to the home network, that one has Ubuntu 7.04 on it. There have been some very strange permission things going on ssince then, like my USB flash drive suddenly requires root permission to mount and unmount, but is that part of this or not.

OK, now I think this is weird and I think it might be multiple problems that occurred synchronously. But where to get traction on solving them I just don't know, can someone jump in and help?

18th May 2007, 11:19 AM
What mobo do you have ? ( common ways to get into bios are F2 or Del and to select boot device F8 , F9 )

The permissions problem with the usb storage may be due to uid Fedora uses uid=500 and ubuntu uses uid=1000

uid = user id

19th May 2007, 03:46 AM
Hi Leigh,
Thanks for your reply, you were correct the key was an F6 for unknown reason (its an Asrock 884 mobo) When I got it I found that the defaults had all reset, why I do not know, but i went through and set up the BIOS again in a friendly way and was off to the races.

I ended up installing Edgy, feisty was relatively hopeless, would not load even with noapic nolapic etc. so I am going to set it up in edgy and then upg to ff, hopefully with no problems. It has been a frustrating week.

I know your name from around the forum so I'll ask a second question to see if you have anything to add. I have two brand new computers, both with a 965 chipset mobo and core 2 chips. It has been a nightmare. I finally got FF to load on this box, but with trouble and the networking issues are still getting worked out, like i can't print to a network printer yet, but it is coming along. The lappie (HP DV621)though is a mind boggler. FF loads, but the xserver crashes so while I have a lovely command line that is all. My teenage daughter is not impressed. I loaded Fedora 6 and got a screen but no network, at all, and various setup ideas haven't panned out.

What I have read is that the 965 is a bundle of trouble that hasn't been untangled yet. Do you have any info on resolution of 965 problems?

Thanks in advance for whatever you know

19th May 2007, 04:06 AM

To get higher resolution with the intel 965 you need 915resolution

su -
yum install 915resolution

this info on 915resolution

resolution modification tool for Intel graphic chipset
915resolution is a tool to modify the video BIOS of the 800
and 900 series Intel graphics chipsets. This includes the 845G,
855G, and 865G chipsets, as well as 915G, 915GM, 945G & 965 chipsets.
This modification is necessary to allow the display of certain
graphics resolutions for an Xorg or XFree86 graphics server.

915resolution's modifications of the BIOS are transient.
There is no risk of permanent modification of the BIOS.
This also means that 915resolution must be run every time the
computer boots in order for its changes to take effect.
If you want to automatically set the resolution on each boot
and before X is launched, see /usr/share/doc/915resolution/README.Debian
for information about configuring the provided initscript.

Homepage: http://www.geocities.com/stomljen/

Have you tried setting up your printer from a web browser using the cups interface



19th May 2007, 04:32 PM
Hi Leigh,
I'll go step by step: The 915 resolution tool fails on install with the message that the mobo does not support it: only the 800 and 900: for a hail Mary I looked for another resolution tool that solved the problem but finally came to the conclusion that I would have to settle for the (miserable) default and wait for the updates.

The printing thing: I haven't used http setup before, usually i use either ipp or smb and have never had trouble. this is a USB printer and I think that the problem lies somewhere in the weird permission thing> If I didn't explain the weird permission thing before: my old Kingston flashdrive will not mount unless I CLI a mount command in the /dev file. same for unmount, moving, copying deleting etc. I tried some chown stuf to get it straight and it claims there is no problem but it also makes no difference either to the permisssions or the device. It won't allow a chown to the /media fileeither, maybe that is normal though since th at is the resulting "face" of the /dev mount.

Anything I put on the drive is also -R'ed with the ownership deal. And this is sometimes happening with the IDE DVD drive, but not the USB CD-RW. Are you confused yet, I am.

Now a number of restarts, switching into the root home and chown ing repeatedly and the problem is slowly resolving. I think it just required perseverence. I will try the printing again tomorrow when I am feeling fresh.

However the problem with the lappie remains. I haven't touched it in the last couple of days. assuming that eventually F7 would come out and hopefully have all this straight, it might be already but the network is completely dead for that baby. If you had a suggestion for that one i'd try it.


19th May 2007, 04:54 PM

Is it a LAN or WIFI connection you need ? does your router use DHCP ?

However the problem with the lappie remains. I haven't touched it in the last couple of days. assuming that eventually F7 would come out and hopefully have all this straight, it might be already but the network is completely dead for that baby. If you had a suggestion for that one i'd try it.


20th May 2007, 02:02 AM
Hi Leigh,
LAN! I'll deal with the WiFi later. And the system uses a hub to connect together four computers: the lappie, the iMac (vintage blue and white G3) and the 2 Pc boxes. DHCP is enabled, at the present time I've got firewalls down to get the system functioning right, but it has been a struggle. Samba is loaded and enabled in everything that has connected. I did a minimal FC6 install just to make it quick and dirty, but we both know that the network stuff should work: notes from memory (mine that is):

the ethernet card was not recognized, loaded or activated. Forcing recognition (probably the wrong term) didn't work, it still wasn't loading on start-up. This is why I blame it on the 965, although it could be unfair-- it seems you think so.

anyway, thanks for your help

20th May 2007, 02:19 AM

If you go to network add hardware is it visible?


20th May 2007, 11:26 AM
I think he will have a greater chance setting up WIFI because there are windows drivers for that... .

rpm -i http://rpm.livna.org/fedora/6/i386/livna-release-6-1.noarch.rpm; yum clean all; yum -y install ndiswrapper


Star with the chapter: Installing Windows Driver (the above is already done).

20th May 2007, 04:15 PM
WIFI assumes there is a WIfi source here in Northern Thailand, well there are a few, but really driving half an hour to play with wifi?.

Leigh, I have been lazy today and my d's lappie is in her room and I was too lazy to fuss with it. I'll check the system-config-network tomorrow PM, as I recall it is not but i'll double check before i act all positive

26th May 2007, 10:02 AM
In administration >Network I have a dropdown box to choose ethernet cards from. it tried to setup eth0 with the first on the list, a 3com card that ain't it. It is an intel on board ethernet card, but I'm not sure which of the three choices it is. I guess i'll try all three. I tried a dmesg to see if it saw a card but it doesn't . perhaps the re is anotehr way to find the hardware that has dribbled out of my head?

26th May 2007, 10:14 AM
Ok, I found the stuff, it is a Realtek RTL 8101E fast ethernet controller (rev 01), My network setup doesn't show this one, but it shows a realtek RTL8129, I'll try it and look for a generic as well. Just as it doesn't show a driver for the AGP (which is also onboard the 965 chipset, it defaults to VESA which has some shamefully low resolutions). I'll keep on it a bit

26th May 2007, 10:17 AM
No go, it doesn't recognize it and won't activate it. now i'm stumped

27th May 2007, 05:37 PM
OK, I just realized that I risk being considered a troll because I started another thread not realizing I was still in FF and not in Linux forums or ubuntu forums. I apologize and will try to figure out how to delete the other entry. Of course nobody seems to be paying attention anyway, but still.

Anyway, the news is that a check at teh realtek website shows that a revised driver for linux was included in a march12 revision to teh kernal, which would explain why ubuntu 7.04 has network working and fedora Zod does not. I am trying to DL 6.93 but am having trouble getting a clean CD out of it. a Thailand thing no doubt.

I am also trying to install Ubuntu7.04 again and do an update in the hopeless hope that it will fix the screen problems, Fedora has no screen problems!
we'll see, I have so many other things to do right now.

27th May 2007, 05:43 PM
Good idea to download test 4 of Fedora 7. To get it 'cleanly' on CD (I assume you are continously facing a corrupted image) I recommend you use torrent. Torrent divides the DVD in pieces (like a few thousends of them). Then the program checks with a checksum which are corrupted and which are not. So if you want to get a good image, use torrent :) .

3rd June 2007, 02:38 PM
Hi Alpha,
The torrent problem here is that I get much faster speeds with using Opera to download: is has a better resume function than FF. anyway, The GD F7 live CD's won't load either. I joined another thread about this problem, it happened with both the 6.93 and the 7 live cd's. Maybe I'll buy a DVD from Singapore and get it sent up here. That thread is 156255 if you want to check that one, it is an entirely different problem, but what the heck, this machine is making me crazy! I am just too confused at this point, (not that i want to go back to windoze, this lappie has vista installed and it takes longer to shut down than my box takes to restart ubuntu and go from up to down to up again.) any suggestions will be tried, I am fearless and clueless: a dangerous combination!