PDA

View Full Version : Recent SDL update problem: Unable to open a console terminal



Pitel
17th May 2007, 01:24 PM
A few days ago, I run yum update, as yousual, and it updated SDL library. But from this moment, every game which uses it crash, saying "Unable to open a console terminal".

# grep SDL /var/log/yum.log
May 15 08:58:37 Updated: SDL.i386 1.2.9-6

When I tried
strace some_SDL_game it ends with
open("/dev/tty0", O_WRONLY) = -1 EACCES (Permission denied). But I don't think changing permissions of /dev/tty0 is a good solution. (And I don's know how to configure udev)

sideways
17th May 2007, 02:09 PM
Maybe the update is buggy, why not go back to the original version, I'm assuming you have FC5 here, you should say so when you post.

You'll need to download the original SDL rpm or get it off the install disc, get SDL-devel if you have that installed too
http://download.fedora.redhat.com/pub/fedora/linux/core/5/i386/os/Fedora/RPMS/


su -
rpm -e --nodeps SDL
(similarly for SDL-devel if you have it installed)


rpm -ihv SDL-1.2.9-5.2.1.i386.rpm

Then exclude SDL from updates via yum by adding this line to /etc/yum.conf

exclude=SDL*