PDA

View Full Version : What causes this? (GTK+ theme is only half-applied)



Firewing1
16th May 2007, 10:14 PM
For some reason when using certain themes they're only half-applied... For example the Foresight theme I grabbed of gnome-look is really nice but in Yumex, Pirut and gdmsetup it looks horrible, as if there was no theme at all (see attachment). What lines do I have to add to the gtkrc to get rid of this? (let me know if you want me to attach it)
Firewing1

Dies
17th May 2007, 01:01 AM
Yumex and some other apps like a lot of the Java ones don't respect those settings so there isn't really much you can do about it, I did file a bug against Yumex for this though.

BTW I don't blame those programs for not wanting to look like that, that theme is horrible. :p

I'm just playing but if you attach the theme I'll play around with it and see if there's any improvement I can make to it. ;)

Firewing1
17th May 2007, 01:31 AM
Sure - It's just a copy of what I downloaded here:
http://art.gnome.org/themes/gtk2/1345
Firewing1

Dies
17th May 2007, 02:03 AM
Alright cool, I'll grab it in a few.

BTW - I forgot to ask are you making this theme available system wide or are you just installing it for your account?

Unless it's in /usr/share/themes, these programs might not have access to it since they all run as root, right?

Firewing1
17th May 2007, 02:05 AM
Aha! That makes sense, I installed it locally only and pirut, gdmsetup and yumex are all root-enabled apps...
Edit: Perfect, that solved it!
Firewing1

Dies
17th May 2007, 03:01 AM
YES!


http://i58.photobucket.com/albums/g277/jerrycasiano/35ttz.gif


I knew something that Firewing1 didn't.

Sure it's silly and not nearly as useful as Firewing's level of knowledge but still... :D

nick.stumpos
17th May 2007, 04:05 AM
love the graphic dies