PDA

View Full Version : FC6 Boot ACPI-FATAL ERROR problems



DeadlyData
16th May 2007, 03:30 PM
On my FC6 server boot it tends to freeze while setting up IP tables the only error above it is...


FATAL: error inserting acpi_freq (/lib/modules/2.6.18-1.2798.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko): n such device


The Full log is


Setting Hostname ~censored~
Setting up logical volume managment
/dev/VolGroup00/LogVol00: clean, 115607/1925760 files, 1078938/1925120 blocks
/boot recovering journal
/boot clean, 33/26104 files, 14197/104388 blocks
Remounting root filesystem in read-write mode: [OK]
Mounting local filesystems: [OK]
Mounting local filesystem quotas: [OK]
Enabling /etc/fstab swaps: [OK]
INIT: Entering runlevel: 5
FATAL: error inserting acpi_freq (/lib/modules/2.6.18-1.2798.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko): n such device
Starting Firewall:


After this the server just tends to freeze... if any one can help me sovle this I'd greatly apreciate it, I can't access the server at all maybe in FailSafe terminal if you can do that before boot is done other then that all I can do is boot a live CD I tried Grub beacuse I was using it to set a partion from before and then I tried going in terminal and mounting the servers HDD and it says it's not a known filetype... so, any liveCD's/or any thing I can do to fix this problem would be greatly apreciated.

leigh123linux
16th May 2007, 03:34 PM
post the output from this command

rpm -qa --queryformat "%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n"|grep kernel|sort

DeadlyData
16th May 2007, 03:37 PM
I can't run commands thats the problem the server just halts to a freeze and then quits booting... allthough I can luanch Gparted LiveCD and it works fine.

leigh123linux
16th May 2007, 03:45 PM
chroot into it from the install dvd/cd

boot it with this option


linux rescue

http://unix.cchem.berkeley.edu/index.php?n=Main.LinuxRescue

DeadlyData
16th May 2007, 03:51 PM
Hmm I was redownloading the distro while leaving the server on and it actulay finally booted.

leigh123linux
16th May 2007, 03:55 PM
Hmm I was redownloading the distro while leaving the server on and it actulay finally booted.


post the output from this command ( fedora can install the wrong kernel i586 instead of i686 )

rpm -qa --queryformat "%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n"|grep kernel|sort




P.S I wont bother asking again

DeadlyData
16th May 2007, 03:59 PM
The reply from the command is


kernel 2.6.18-1.2798.fc6.i586
kernel-headers-2.6.18-1.2798.fc6.i386


Sorry for not running it last time thanks again for the help... what should I do now?

leigh123linux
16th May 2007, 04:21 PM
do

su -
yum update kernel
su -c "yum install yum-utils"
yumdownloader kernel.i686
su -c "rpm -ivh --replacefiles --replacepkgs kernel-2*.i686.rpm"

reboot

http://www.fedoraforum.org/forum/showthread.php?t=139751

DeadlyData
16th May 2007, 04:27 PM
Thanks no more errors on boot..

leigh123linux
16th May 2007, 04:38 PM
Thanks no more erros on boot..


If you post your graphics card type I will post a howto for it ( if appropriate )