PDA

View Full Version : If someone can help me enable Java in Opera...



Reisswolf
14th May 2007, 01:40 AM
...I'll give him the rights to my imaginary holiday mansion in the south of France.



[roy@localhost ~]$ uname -a
Linux localhost 2.6.19-1.2895.fc6xen #1 SMP Wed Jan 10 19:47:12 EST 2007 i686 i686 i386 GNU/Linux


[roy@localhost ~]$ rpm -q opera
opera-9.20-20070409.6


[roy@localhost ~]$ /usr/sbin/alternatives --display java
java - status is manual.
link currently points to /opt/jre1.6/bin/java
/usr/lib/jvm/jre-1.4.2-gcj/bin/java - priority 1420
slave keytool: /usr/lib/jvm/jre-1.4.2-gcj/bin/keytool
slave rmiregistry: /usr/lib/jvm/jre-1.4.2-gcj/bin/rmiregistry
slave jre_exports: /usr/lib/jvm-exports/jre-1.4.2-gcj
slave jre: /usr/lib/jvm/jre-1.4.2-gcj
/opt/jre1.6/bin/java - priority 2
slave keytool: (null)
slave rmiregistry: (null)
slave jre_exports: (null)
slave jre: (null)
Current `best' version is /usr/lib/jvm/jre-1.4.2-gcj/bin/java.
[roy@localhost ~]$


I have tried enabling it from the Preferences submenu under the Tools menu. When I click the button labelled "Validate Java path" Opera says that the specification is valid. Yet, I cannot view any Java applet in Opera. Moreover, the Java option switches off by itself after one failed attempt to load a Java applet.

I have searched on Google; I have searched on Opera's forums; I have even searched these forums. But I have not found any answer yet.

Some help would be greatly appreciated.

Wayne
14th May 2007, 02:31 AM
I don't know if this will help:

Wayne

Reisswolf
14th May 2007, 07:11 AM
Unfortunately, Wayne, as already noted in the original post, this method does not work. It is really frustrating.

Wayne
14th May 2007, 07:16 AM
Unfortunately, Wayne, as already noted in the original post, this method does not work. It is really frustrating.

As can be seen it can and indeed does work. Just a WAG, SELinux?

Wayne

Reisswolf
14th May 2007, 08:50 AM
I am thinking that it has more to do with motif. It is possible that Opera does not play well with lesstif. Can you please check if you have motif installed on your system?

Wayne
14th May 2007, 09:00 AM
I am thinking that it has more to do with motif. It is possible that Opera does not play well with lesstif. Can you please check if you have motif installed on your system?

Get nothing in return when I do a search.

Wayne

pete_1967
14th May 2007, 11:35 AM
Opera needs the path to libjava.so (`locate libjava.so`) (e.g. if you get "/usr/java/jre1.6.0/lib/i386/libjava.so" in the Opera's Preferences -> Advanced -> Content select the "Enable Java" box and click the "Java Options" button. Paste the path (e.g. /usr/java/jre1.6.0/lib/i386/) in the box and click "Validate Java Path" to make sure you gave it correct location.

After you've done that, restart Opera and go to http://www.java.com/en/download/help/testvm.xml to check all works.

stanmc
29th May 2007, 04:26 PM
Unfortunately, Wayne, as already noted in the original post, this method does not work. It is really frustrating.
Did you ever get it to work? I have two FC6 systems. One is listed below, and using the 2.1 version of opera and Java 1.0.6_01 it works. My portable, however, displays the same problems you delineated above. The portable also uses the 2.1 version of opera and the 1.0.6_01 of java. The portable works when I am logged in as root and it verifies with the Sun site. But, as a normal user it does not. My versions of FC6 are both i686. This only began to happen when I installed the 2.1 version of opera. My screens match Wayne's examples except for the java version.

ahvi
8th June 2007, 07:29 PM
Wow, I can't believe how ridiculous the solution was for me. I had the exact same problem where java kept switching off. Turns out that SElinux didn't like the way java opened with opera, something to do with text relocation. So it told me to temporarily bypass it with the following command. Obviously replace the path with wherever it is in your computer.

chcon -t textrel_shlib_t /opt/jre1.6.0_01/lib/i386/client/libjvm.so
It worked hah, after hours of complex solutions, Fedora was the problem. Alrighty, maybe this will help someone else?

krell
16th June 2007, 05:12 PM
Wow I just tried that and Opera Crashes now!
Before it would just sit there twirling its cpu while saying the applet was loaded
(but the input area of the applet was not active)

My Selinux settings are at PERMISSIVE level.
Maybe that makes a difference. I would have thought it would make doing this stuff easier

ahvi
17th June 2007, 04:21 AM
To my understanding, the only thing that the "chcon -t textrel_shlib_t" command does is make an exception in SELinux for the file if text relocation was the reason that it was being stopped. Does Opera work normally when not trying to load java applets? If so, then the reason Opera crashes now is because it's actually using the java plugin and there is a problem with it. I would try re-installing the plugin and make sure you get the right version. Good Luck.

krell
17th June 2007, 04:35 PM
I think your right..It's either my install or a buggy plugin.
Other plugins, realplay and flash seem to work.

I'll try again

ja1217
18th June 2007, 04:05 AM
I'm not sure if this could be your problem or not. For some odd reason, the most recent release of the java plugin (1.6 or something) does not work on all hardware. I had the same problem with my laptop. No matter what I did or how closely I followed instructions, it simply would not work (in both fedora and windows). As soon as I moved back an older version of the plugin (1.5 something) everything worked just fine.

Just give it a try with the older version of the plugin, if that doesn't work, I'm afraid I can't help. Here is a link to the older version of Java. http://java.sun.com/javase/downloads/index_jdk5.jsp

krell
18th June 2007, 01:58 PM
Thanks but if that means i have to downgrade Java to 1.5..well I'll just use firefox or even konqueror for java applets.
or maybe run it in my virtual Fedora when I get that installed(by the way...VMware is a great tool for testing
this kind of stuff)

ja1217
19th June 2007, 01:05 AM
Thanks but if that means i have to downgrade Java to 1.5..well I'll just use firefox or even konqueror for java applets.
or maybe run it in my virtual Fedora when I get that installed(by the way...VMware is a great tool for testing
this kind of stuff)

If its the same problem I had, it won't matter if you run Firefox (don't know about Konqueror, don't use KDE). The only option I had was to downgrade to 1.5.

krell
19th June 2007, 01:45 PM
By Jove I think you are right.. I ran the jin STANDALONE application
last night using Java 1.6 and it CRASHED (bad Frame blah blah).
That is the same or very similar to the error when running the jin applet in Opera.
This is the first time it has happened to me and I know that program is stable on windows
as I have been using it for years with not a hiccup.

Looks like Java 1.6 is buggy on linux..but I don'y hear much about this when I do a google
search.. I wonder if Sun is working on this..

krell
24th June 2007, 03:30 AM
Ok i've installed the new Java 7 BETA from Sun
and no longer have stability problems in my java Aplications.

The java applet in Opera , while better, is still unstable. Maybe I need to configure
more..

More good news.. Opera 9.25 beta should be ready for testing in a few weeks (story on /. or digg)
They say linux support will be much better :)

Reisswolf
24th June 2007, 07:33 AM
Yes, but it is annoying that Opera will not put out a 64-bit version. Ever since my switch to 64-bit Linux with Fedora 7 I have been discovering that the 64-bit platform is not as widely supported as it should be.

ahvi
24th June 2007, 07:39 PM
Yeah, I actually got so fed up that I switched back to 32bit