PDA

View Full Version : Updates that won't install



melm2
14th May 2007, 01:26 AM
Greetings. I'm running FC6 and somewhere along the way I've set up to install new programs and I now get offered to update some programs that then tell me that it cannot install the dependencies. How do I get them to stop trying to install? Either I'm not asking the search function the right question in the right way or there isn't an answer to my question so far. Any assistance will be appreciated.

Wayne
14th May 2007, 01:34 AM
Greetings. I'm running FC6 and somewhere along the way I've set up to install new programs and I now get offered to update some programs that then tell me that it cannot install the dependencies. How do I get them to stop trying to install? Either I'm not asking the search function the right question in the right way or there isn't an answer to my question so far. Any assistance will be appreciated.

Open a Terminal, su to root and post the results of typing:

yum update

Wayne

Wayne
14th May 2007, 01:37 AM
Of course you could type:

yum update --exclude=packagename

to stop it from updating that particular package but I was just curious that you might have a repository conflict.

Wayne

melm2
14th May 2007, 01:39 AM
I assume you want me to run the command and let you know what I get?

Wayne
14th May 2007, 01:41 AM
I assume you want me to run the command and let you know what I get?

Absolutely! See my second post for the madness to my method!

Wayne

melm2
14th May 2007, 01:43 AM
I'm pretty sure I have a repository conflict because I've been trying to get multimedia to work and I followed one of the examples. I'm booting up my other machine now so I'll post again soon.

Wayne
14th May 2007, 01:47 AM
I'm pretty sure I have a repository conflict because I've been trying to get multimedia to work and I followed one of the examples. I'm booting up my other machine now so I'll post again soon.

This is for FC5 but the warning applies to all versions of Fedora:

http://stanton-finley.net/fedora_core_5_installation_notes.html#Warning

It's up to you to decide whether or not to have Dries/Freshrpms OR Livna active. There are instructions there to keep the repos available but inactive until you need them.

Wayne

melm2
14th May 2007, 01:54 AM
Those are the instructions I was following. All the dependencies are related to lib's for gfx files. Such as xblast, wormx, openlierox, per-sdl, and a few others. I'll try your suggestion for excluding them. Thanks. By the way, I like your tag line.

Wayne
14th May 2007, 02:00 AM
Those are the instructions I was following. All the dependencies are related to lib's for gfx files. Such as xblast, wormx, openlierox, per-sdl, and a few others. I'll try your suggestion for excluding them. Thanks. By the way, I like your tag line.

Those are games, right? I would guess that they require an older version of some library or other and there is a new version of that library available. I've seen this on my son's machine. I sneakily removed the offending game to update the lib and I think he hasn't noticed :D Well, he hasn't said anything..... yet! :rolleyes:

Thanks, by the way. I just wish it were time for a cold one :eek:

Wayne

melm2
14th May 2007, 02:05 AM
Thanks, I'll try the exclusion method first. I have no idea if they are games or not. It's time for a cold one here but I've been drinking wine for the last 6 hours so I'll stay away from the beer until tomorrow. BTW, I'm in Raleigh, North Carolina, USA.

Wayne
14th May 2007, 02:09 AM
Thanks, I'll try the exclusion method first. I have no idea if they are games or not. It's time for a cold one here but I've been drinking wine for the last 6 hours so I'll stay away from the beer until tomorrow. BTW, I'm in Raleigh, North Carolina, USA.

I'll use your time-zone as an excuse to raid the fridge :D It's still only 10:09am here.

No, wait a minute, got things to do today, maybe later ;)

Wayne