PDA

View Full Version : Time not stable



ArneLovius
10th May 2007, 10:34 AM
Hi,

I have FC6 installed and working fine under Microsoft Virtual Server 2005 R2 apart from one very annoying "bug", the clock drifts enormously (tens of minutes per day). On the "console" I get the following "TSC appears to be running slowly, Marking it as unstable".

I found a web page (http://support.microsoft.com/kb/918461) that suggested setting clock=pit, then discovered that it had been deprecated and then tried clocksource=pit. Unfortunately neither of these reduce the clock drift.

I've tried it with and without "Host time synchronization" set in Virtual Server to no avail.

I've runing ntpd, again to no avail, which I think might be related to the speed at which the "hardware" clock is drifting.

I don't have this problem with Windows, DOS or OS/2 running under Virtual Server.

I'd appreciate any pointers to help me reolve this

Cheers

Arne

I'm running kernel 2.6.20-1.2948

drunkahol
10th May 2007, 12:33 PM
I'd like a solution to this too.

We run many RHEL4 WS virtual machines on VMware at work. All of them suffer from clock drift.

Our "solution" is to configure ntp to keep as close to the right time as possible.

It's a tricky one though.

Duncan

huw-l
10th May 2007, 06:20 PM
they've apparantly fixed this in VMWare ESX..

I've heard it said that turning off cpuspeed on the vmware host helps, but I haven't tried it personally.

This is one of the reasons I'm currently playing with Xen

paulMOA
10th May 2007, 08:00 PM
I would try adjtimex (from man -k clock). Sorry I am not using FC6 so this may not be much help.