PDA

View Full Version : Graphics Woes



electroconvulsi
4th May 2007, 06:07 AM
After a recent update my wIndow border dissapears on a regular basis. I have tried booting into the old kernel to see if the kernel update was the problem and the problem seems to presist there as well.

I am using compiz. My Pc is made up of a P4 3.0ghz CPU, Gigabyte 8IPE motherboard, M-Audio Delta 66 Sound Card and a Nvidia fx 5500 video card. I have checked my /etc/X11/xorg.conf file and as far as I can tell nothing is wrong with that either but I am providing it in case I missed something.

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1152x864" "1152x768" "1024x768" "1024x768" "800x600" "800x600" "640x480" "640x480"
EndSubSection
EndSection

Hopefully this will clue someone a little more knowledgable than me as to what is going on here. Thanks in advance for any help given.

Seve
4th May 2007, 12:33 PM
Hello:
If you are using compiz, try adding to the end of your /etc/X11/xorg.conf file:

Section "Extensions"
Option "Composite" "Enable"
EndSection
HOWTO: Compiz with NVIDIA Graphics Drivers (http://www.nvnews.net/vbulletin/showthread.php?t=77030)


Seve

electroconvulsi
4th May 2007, 05:04 PM
Thanks Seve the problem was happening intermittently so I cant tell yet whether the solution worked or not but Ive had it running for 20 minutes and there has been no problems so far and so as far as I can tell the solution worked. I'm at a loss as to how this section of my xorg.conf either disappeared or was never there and I had no problems but weirder things have happened to me under Linux. Check this post out http://ubuntuforums.org/showthread.php?t=418284I think you may have already seen it because you've helped me over at the Ubuntu forums. Hey don't worry trying to figure that one out I just ended up reinstalling my system because it was too much of a mystery for me.

Anyway you have shone again and I thank you ever so much.