PDA

View Full Version : mythtv & atrpms install problems



relay01
22nd April 2007, 01:50 PM
Hi,
I have a general question also since I was following the main myth tv install how to, which leads you to install atrpms into your repositories, before I found the sticky article about the dangers of atrpms, I believe I've suffered a problem as a result. the first time I attempted to install mythtv appeared not to work well. It down't recognize a mysqld command like the tutorial says it's supposed to, and when I try and install mythtv, i get the following output
[('file /usr/lib/libpostproc.so.51.1.0 conflicts between attempted installs of libpostproc51-0.4.9-20_r8743.fc6.at and ffmpeg-libs-0.4.9-0.35.20070204.lvn6', (6, '/usr/lib/libpostproc.so.51.1.0', 0L)), ('file /usr/lib/libavutil.so.49 conflicts between attempted installs of libavutil49-0.4.9-20_r8743.fc6.at and ffmpeg-libs-0.4.9-0.35.20070204.lvn6', (6, '/usr/lib/libavutil.so.49', 0L)), ('file /usr/lib/libavcodec.so.51 conflicts between attempted installs of libavcodec51-0.4.9-20_r8743.fc6.at and ffmpeg-libs-0.4.9-0.35.20070204.lvn6', (6, '/usr/lib/libavcodec.so.51', 0L)), ('file /usr/lib/libavformat.so.51 conflicts between attempted installs of libavformat51-0.4.9-20_r8743.fc6.at and ffmpeg-libs-0.4.9-0.35.20070204.lvn6', (6, '/usr/lib/libavformat.so.51', 0L)), ('file /usr/lib/vhook/drawtext.so conflicts between attempted installs of ffmpeg-0.4.9-20_r8743.fc6.at and ffmpeg-libs-0.4.9-0.35.20070204.lvn6', (6, '/usr/lib/vhook/drawtext.so', 0L)), ('file /usr/lib/vhook/fish.so conflicts between attempted installs of ffmpeg-0.4.9-20_r8743.fc6.at and ffmpeg-libs-0.4.9-0.35.20070204.lvn6', (6, '/usr/lib/vhook/fish.so', 0L)), ('file /usr/lib/vhook/imlib2.so conflicts between attempted installs of ffmpeg-0.4.9-20_r8743.fc6.at and ffmpeg-libs-0.4.9-0.35.20070204.lvn6', (6, '/usr/lib/vhook/imlib2.so', 0L)), ('file /usr/lib/vhook/null.so conflicts between attempted installs of ffmpeg-0.4.9-20_r8743.fc6.at and ffmpeg-libs-0.4.9-0.35.20070204.lvn6', (6, '/usr/lib/vhook/null.so', 0L)), ('file /usr/lib/vhook/ppm.so conflicts between attempted installs of ffmpeg-0.4.9-20_r8743.fc6.at and ffmpeg-libs-0.4.9-0.35.20070204.lvn6', (6, '/usr/lib/vhook/ppm.so', 0L)), ('file /usr/lib/vhook/watermark.so conflicts between attempted installs of ffmpeg-0.4.9-20_r8743.fc6.at and ffmpeg-libs-0.4.9-0.35.20070204.lvn6', (6, '/usr/lib/vhook/watermark.so', 0L))]

Is there anyway to fix this mess. I'd also like to note that before I installed MythTv, I could play dvd's... and now it won't play them anymore. Could this be a problem with atrpms? Is there anyway to fix this?
Any help is greatly appreciated and if you need more info, let me know. Thanks

ramasees
22nd April 2007, 02:02 PM
looks like you have livna or freshrpms installed as well you should really have only one of these enabled at one time dissable the others and this should solve your problem

relay01
23rd April 2007, 03:30 AM
this will only keep me from screwing up again... I need to know how to fix it... I disabled atrpms and still get the same problem when installing.

lazlow
23rd April 2007, 04:01 AM
Relay

The fastest and safest way out is to do a clean reinstall. Nobody wants to hear this. I did not want to hear it when I did it to my FC4 install. But it is about the only reasonable way to make sure that you got it all in a short amount of time.

Lazlow

warnockm
25th April 2007, 05:22 AM
I had this problem and disabled livna and it installed perfectly. No need to reinstall.