PDA

View Full Version : Globe7, SELinux, chcon



nariknahom
15th April 2007, 10:24 AM
I installed Globe7 (http://www.globe7.com/linuxfeatures.php) for fc5 i386 on my laptop running FC6 x86_64. The installation went fine without any errors/warnings. But when running globe7 i get the following error
--------------------------
chcon: can't apply partial context to unlabeled file /usr/lib/site_ruby/1.8/i386-linux/pcap.so
chcon: can't apply partial context to unlabeled file /lib/libavcodec.so
chcon: can't apply partial context to unlabeled file /lib/libglobe7url.so
chcon: can't apply partial context to unlabeled file /lib/libgtkembedmoz.so
chcon: can't apply partial context to unlabeled file /lib/libngbapi.so
chcon: can't apply partial context to unlabeled file /lib/libportaudio.so
chcon: can't apply partial context to unlabeled file /lib/librt-2.5.so
--------------------------

I found that this has to do with SELinux. But SELinux is disabled.

--------------------------
[root@dhcppc2 ~]# cat /etc/sysconfig/selinux
# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
# enforcing - SELinux security policy is enforced.
# permissive - SELinux prints warnings instead of enforcing.
# disabled - SELinux is fully disabled.
SELINUX=disabled
# SELINUXTYPE= type of policy in use. Possible values are:
# targeted - Only targeted network daemons are protected.
# strict - Full SELinux protection.
SELINUXTYPE=targeted

# SETLOCALDEFS= Check local definition changes
SETLOCALDEFS=0
----------------------------

Pls help me get rid of this error.

sideways
15th April 2007, 10:47 AM
It seems to stubbornly want selinux context labels, even though you don't use selinux!
Try

su -
fixfiles restore /lib

nariknahom
15th April 2007, 10:56 AM
Tried 'fixfiles'. But getting same error.

sideways
15th April 2007, 11:14 AM
You may have to enable selinux (use system-config-securitylevel, don't do it manually, permissive or enforcing mode), reboot to relabel the entire disc and then leave it set to permissive mode, which means it won't prevent anything but will allow files to be labelled correctly.

parda
17th April 2007, 11:05 AM
hai friend

u r running on user (for ur user).

can u run globe7 on root once and exit and run in usr?

u r problem will solve?

globe7 won't run on FedoraCore 6.

bye
parda